Urgently Need Help: Print Job intermittently delayed/staled

Hi Guys,

My brother just opened a restaurant a few days ago and I helped him set up the POS system with Sambapos v4.

The system is up and running, but it has this issues with the print job. When the system is being trialled with constant transactions and printing, it works. But it’s left idle for sometime without any transaction, the print job is no longer working (together with the cash drawer not opening). Sometimes it will print again and open the cash drawer after a few mins when the transaction is over or sometimes not at all. At times, turning off the printer and turning it on would trigger the print job back on.

Is there any setting that I’ve missed with the printer setup? I should have trialled the system long enough before I put it online but infortunately the request to set it up came in late and very last minute.

You help is greatly appreciated.


What kind of printer and how is it connected? Also show us the setup under samba settings for the printer.

Forgot to mention, I’m using Samba POS v4.1.79 with Epson TM-U220B, linked with Cash Drawer Posiflex CR-4000. I set them all up following the posted tutorials and they work well. It just starts to have problem when left idle for sometime, and it’s getting worse by the day.


How is the U220B connected, Ethernet?

The printer is connected via USB, and the cash drawer to the printer with RJ11. Thanks.

And you downloaded the latest “Advanced Printer Driver” from epson’s site, installed it and chose your U220B exact model?

Also did you choose ticket printer under the samba settings for the settings of the printer thats having issues?

Also when you are having this issue go to windows printer settings and try to print a test page to that printer.

Yes, I did downloaded the latest from Epson site and select the exact printer model.
Yap it was ticket printer as the printer type. I haven’t tried to test print from windows, let me try now I’m on my way to the restaurant now as it’s creating quite a mess people can’t get their receipt out.

I’ll post again as soon as I’m there.


Im sure it did. Ill be here.

Hi eddhasaj,

It didn’t work and I just noticed one thing, windows is actually complaining not recognising the USB device. So it’s driver issue? I installed the driver from https://download.epson-biz.com/modules/pos/index.php?page=prod&pcat=5&pid=42 and pick TMU220 (without the suffix as there is only this option.

Thanks for your help.

Ok try to delete the printer and reinstall it. Also plug in the usb in the ports in the back of the desktop instead of the front.

Also try to restart the windows spooler services


I just did and I am using a laptop (spare) to set this up. After reinstalling, test print works. I open sambapos, tried to print, nothing, and I see the USB not recognised/malfunction message again.:frowning:

Try to print from another program see if that works. Keep in mind that is 100% not samba. Its either hardware issue with the printer or usb ports on desktop which I highly doubt, I think its your setup in windows when you installed the driver or most likely how you setup the printer in samba,

Did you restart the print spooler yet

go to control panel - system and security - administrative tools - services - double click print spooler stop then start

As soon as i got a message that the USB device is not recognised, printing from anywhere is not working. Even test print wont work. That’s probably why sometimes turning off and on the printer work because it’s re-recognising the printer again. But then it’ll get unrecognised after.

So what triggers the issue is when you try to print from samba?

Can you please post a picture of the printer setup and printer template

Someone else who had a similar issue posted this. Do you think that could of been your case too?
The issue was bound to the fact that when I initially plugged in the printer without the Epson drivers installed, windows created registry entries relating to the hardware ID and associated the wrong driver. Even when I uninstalled both the epson hardware and the windows associated driver it left the registry entries untouched so when I plugged the device in again it went straight to them.
I had to restore the factory install of windows to its initial state (but Im sure a restore point just before the printer was ever plugged in, or manually deleting all of the relevant reg keys would have sufficed). Then I had to install the driver before plugging in the printer. Otherwise nothing works ever.

I actually did came into this post before I set the printer up. And no, I didn’t connect the printer at all until driver is installed. So I am pretty sure it’s not exactly the same issue. Just a sec I will post the setting.

Apparently new user cant upload images. Here’s my setting:

Ticket Printer
Port:Epson TM-U220 Receipt
Printer Type: Ticket Printer
Char set: 857
RTL Support: None
Line Count: 0
Character Count: 40
Char Replacement: empty

Ticket Printer mapped to Ticket Template in Print Jobs, and TIcket template contains pretty much just Receipt formatting, no printing command or the likes.

Appreciate your help.

Did you restart the spooer yet?

go to control panel - system and security - administrative tools - services - double click print spooler stop then start

Yes I did. Now the printer is not regonised at all.

USB can be unreliable sometimes. I suggest you try a new cable, keep it short as possible.

On some occasions USB connections fall asleep and restarting the printer usually resolves this.

What’s the recommended connection type? The laptop only has USB and ethernet.

And why is it that, if I don’t start sambapos with the printer freshly installed, its good and printing test page. But as soon as I start sambapos, it becomes unrecognised immediately?