V5 5.5.4 - Reverts to Demo

This is very isolated case that I cant figure out.

Every time computer is turned off and restarted, SambaPOS reverts back to Demo.

When opened, before license is activated it gives and error “One or more errors occurred”.
Attempting to Login makes it crash.

Leaving no traces in the log file why.

Additionally, attempting to login with license credentials will give an error “Email/Password Error”

We are currently on 5.6.2 soon we will release 5.6.4. Can you try latest version? It may not solve it but we are working on several versions after 5.5.4

I downgraded from 5.6.2 to 5.5.4 because that’s the version it started happening on.

I am not sure what other details i can give you, there is nothing in logs, and I cant access Management to enable Detailed logs because it crashes as soon as I try to press → button to login.

Delete the tables from dbo.LicenseAddons then run licensing.exe again on the server. Then start sambapos see if that helps. Licensing is handled by the registry. Did anything change in the hardware? Or is anything clearing the registry?

You mean when you run licensing.exe? Did someone change the password? What is the cp account? Can you try password recovery?

Ive tried doing that too, deleting rows in LicenseAddons table.

It doesnt help. Honestly no idea where its stuck or why its stuck. Nothing changed on the hardware or the software

Yes, when I run licensing. No one changed the password. Can login on cp.sambapos.com, but cant login with same credentials in Licensing.exe.

I took an extra step to type it up in notepad without any styling or things copying might collect while on the website. It doesn’t work.

Ok can you let me know the license email we can check it.

we get the same error here in NZ

every time a device powers off/on we have to re-license it… Just downloading latest version to see if it still happens…

very annoying when out tables power down at night I have to apply the license each day

if you found the answer/solution please let me know

I have a gotten the results I wanted in the end but I did quite a few things and it took 2-3 hours:

  • Fresh install of Win10
  • Fresh install SQL Server
  • Fresh install SSMS
  • Fresh install SambaPOS 5.5.4
  • Deployed database
  • Setup Connection String in SambaPOS
  • Changed password on cp.sambapos.com, I specifically changed password so it doesnt include any symbols or odd characters
  • Closed SambaPOS
  • Licensing.exe

Since then there has been no issues with licensing.