V5.5 Licensing across users

I have just upgraded to v5.5 in one restaurant and have had some trouble with the new licensing system.

My upgrade process was to take a database backup, close SambaPOS on all terminals and then upgrade on the main terminal, and run Licensing.exe which worked fine.

I then upgraded the remaining terminals. Of the four other terminals, three picked up the licence without issue and the last remained showing “DEMO”. I tried resetting SambaPOS and restarting the terminal in question, and the main terminal, to no avail.

I have each terminal set up with two user accounts - POSuser which is non administrator and signs in automatically, and POSadmin which is an administrator account and password protected. As such, I installed SambaPOS on every terminal through the POSadmin account.

The main terminal when signed into POSadmin was showing as activated but when signed into POSuser was not.

With the old licensing system, this meant signing into SambaPOS and pressing activate in Marketplace for each Windows user account. With the new system, this wasn’t possible to do in the POSuser account as Licensing.exe was throwing a .NET framework error due to trying to write to the reigstry without permissions. Running Licensing.exe as administrator (using POSadmin credentials) while signed into POSuser did not work - presumably it is trying to store something to the registry that is user-specific but requires administrator access of some sort?

My fix for this was to give administrator permissions to POSuser, run Licensing.exe as POSuser, and then remove administrator permissions. I had to do this on the main terminal and the other that was giving issues.

For the other three terminals (one of which has a number of differently named Windows accounts used for remote access from tablets), I didn’t need to run Licensing.exe at all and each Windows account works fine. I’m not sure what the difference was between these three and the other terminal that had the problem.

Is this intended behaviour? Should Licensing.exe require administrator permissions to change user-specific registry keys? Ideally licence installation would be once per terminal/Windows installation given that there aren’t any licence restrictions imposed about concurrent users or sessions, no?

Error details

Full error text: See the end of this message for details on invoking just-in-time (JIT) debuggi - Pastebin.com

Try running the licensing executable as administrator.

Can you please send an email to support@sambapos.com for this?

Have done so now. Thanks