V5 Convert LocalDB 2014 to SQLExpress 2014


After playing around with my database for so long, ready to finally make my server. Any guides on how to convert from my standalone localDB to SQL? Have already set up SQLExpress and added the data connection string. Tried importing my zip file but it comes up with the error

"The media on device Admin\Desktop\SambaPOS5_Full.bak is incorrectly formed. SQL Server cannot process this media family. RESTORE FILELIST is terminating abnormally.

Tried searching but only found out hits from V4 on how to convert from CE to SQLExpress, but V5 doesn’t use CE.


EDIT: Using SQLExpress 2008. Version 2014 wouldn’t install, kept hanging on “dotnet32 install” for hours. Then Version 2012 wouldn’t even load as it kept saying “please close the other SQL setup” even though none were open. Hence had to resort to 2008.

All you do is run a backup of your LocalDB then restore that backup while connected to your SQL Server instance.

1 Like

You have to install .net 3.5 by going to Control Panel > Programs > Programs and Features then click Turn Windows Features on or off and install .net 3.5

1 Like


Getting a new error now:
"The database was backed up a server running version 12.00.2000. That version is incompatible with this server, which is running version 11.00.3000.

I thought this was due to the SQL, so i managed to upgrade from 2008, to 2012 and now to 2014.
Still getting the same error now even on SQL Express 2014. Any ideas?

My plan now: Remove all other SQLs and leave 2014 remaining. Will see if it works

(The back up was made on my laptop running SQL 2014 LocalDB)

You are correct.

V11 is 2012
V12 is 2014

Ok, hunch was right. Finally managed to get sql 2014 sorted, restored the database and the connection string updated successfully.

Next problem (sorry guys and girls)!

When setting up my 2nd terminal it fails to connect. (instance, username, password are all the same as the server one, triple checked it)

Any ideas? Screenshot of SMSS below which confirms SQL server installed correctly.


Take a look here for common connection issues.

1 Like

The default installation of SQLServer Express will create an Instance called computername\SQLEXPRESS.

Installing SQL Server LocalDB via SambaPOS installation creates an Instance called (localdb)\V11.0

Installing SQL Server LocalDB manually (outside of SambaPOS installations) will by default create an instance called (localdb)\MSSQLLocalDB

It is good to keep in mind that an Instance is not the same thing as a Database. For example, my SQLEXPRESS Instance contains 7 Databases with the names like [SambaPOS3], [SambaPOS4], [SambaPOS5]. Though there is nothing wrong with, and nothing stopping you from renaming the Instance during installation to be SAMBAPOS… just know that the Instance is not the Database.

:exclamation: The SQL Server LocalDB versions do not install as a Service; instead they are simply a Process called sqlservr.exe, which you should see in the Task Manager.

If you are using SQLExpress, the Instance is shown in Services. Ensure it is set to Start Automatically.

If the Service is not shown as Started, then you have an issue with Service Startup in Windows, likely due to the way it is set to start or due to permissions.

In your case, it looks like you need to set all terminals to attach to:

Data Source=Admin-PC\SAMBAPOS2; User Id=sa; Password=sambapos; Database=SambaPOS5

It is more reliable to give the server a Static IP and use that IP Address rather than the Computer Name.

Besides that, there is more to multi-terminal setups having to do with ensuring the SQL Browser Service is running on the Server, and allowing applications and/or ports through the Windows Firewall on the Server.

The link provided by @Jesse is a good resource.

I also went through a lot of trial and error, and came up with this:

1 Like

You should specify a database to connect too. Looks like yours is called SAMBAPOS5

Thanks both of you, will crack on with the bedtime reading and update you tomorrow. Appreciate it as always. Almost 3am here :flushed:


No joy.

Could this be the cause of my problems? Tried to start the service through task manager and got this error

Then loaded up services via control panel and it shows this.

Two words.

Sorted. Added database name, and then opened ports.


Thanks a lot, really appreciate your time and effort to help.

1 Like

Also just worth to note, SQL Agent (the service that is stopped in your screenshots) is not available or used in SQL Express edition. It only works in SQL Standard and above. I have no idea why it gets installed with SQL Express but that’s the reason it’s stopped and also it should be at Disabled status, not Automatic. I think you might have changed that?

If I try to start SQL Agent on my system, it just starts then stops, which is expected behaviour.


Helo kendash i have a problem with that it shows the error “Sistemerror Access denieded to the backup file” …
i put the image but its in german… :slight_smile:

The error is self-explanatory. SambaPOS does not have access to the file because it is in a location where Access is Denied.

Move the backup file out of your user directory to somewhere else where SambaPOS has privileges to access the file, such as the root of the C: drive.

failing that search the forum for

NT Service\MSSQL

You can give SQL the permissions for a directory to overcome this also.

i changed the location to C: but it shows allways this

often C:\ is not accessable either. Its best to put it on a separate drive. Or give the user correct permissions to C:


I have just had this issue with SQL Server 2014.
It turns out all I had to do was tick the box marked ‘Relocate all files to folder’ on the ‘Files’ section: