V5 Invalid Printer Error and Print Template Issue

Hello All,

I have an environment where the Database was migrated from v4.1.82 to v5.1.62. Everything works except for the following 2 critical issues that impacting operations.

Issue 1:- Invalid Printer Error

I have 2 Epson TM T2- Ethernet Printers, 1x named “EPSON_Kitchen1” and 2nd named “EPSON_Front1”. The printers are Ethernet cable connected with fixed IPs. The OS is Win2008 R2 on server and Win8 on Tablet.

The printers are working well at the OS level and prints test page all fine. The issue is Sambapos, I have set the printers to EPSON_Kitchen1 and EPSON_Front1 appropriately in the settings and test print fine.

When I log out and log back in, the printer is no longer recognised ie: “Invalid Printer” message pops up every time a print Action is carried out. The fix is to go back to the Settings and re-assign the printers, although the printers are already listed in the settings box… Just by reselecting the Printer again, it starts working.

The problem is worse when I logon to the tablet, the server session starts popping up the “Invalid Printer” message and vice versa.

I have no clue where to start troubleshooting especially when at the OS level everything is fine.

Issue 2 : Printer Template issues with entities

I have a Kitchen Display setup, basically the one developed by JohnS. In v4 we had everything working where, the tickets will have Table Name or Customer Name up top in the display/printer and the order itself as per standard.

After the upgrade some Entity items show and others don’t, there is no explanation as to why this happens. For example a customer with the name “Takeaway1” displays correctly but “Bernard” doesn’t. Any new entity created such as new customer “John Smith” doesn’t display at all.

Please help as this is in production now and causing major headaches. Thanks in advance.


It have kitchen display tutorial for v5 you can compare your template with the that and see where is the problem.
Show the printer settings

Hi Faisal,

Thanks for the response, just wondering why do you think there is a problem with the template… as some customer name prints and others don’t?

What printer settings would you like to see to assist in this matter? The OS level or Sambapos settings?

@emre sorry to target this direct at you in desperation , but I am in a bit of bind and happy to pay for support. Any guidance is appreciated. Thanks

Emre is away from forum at the minute working on next version.
You need to share more info, many have complex multi printer setups so likely a config issue.
Please share screenshots of you printers os setup, printers list, printer and print job setup in samba.

Network printers are best setup directly on each device, and given the same name on each terminal allowing for a single printer in samba and single print job.
Printer name is a global value and samba only looks to local Windows printer name list so wether individual or centeral printer if named the same on each machine should be good with single job etc.


@JTRTech thanks for your input and apologies for the delay as I tried to further troubleshoot these issues myself. Here is the outcome :

- Issue 1 - “Invalid Printer” was resolved following these steps

  • Remove Terminal Name from “Server”

  • Delete all Terminals in the list

  • Delete Sambapossettings.txt

  • Issue 2 - Still pending, please see attached zip files with all applicable screen shots. The ENTITY NAME variable does not seem to work in the Kitchen Display. As you can see in the screenshots attached, some ENTITY NAMEs display well ie: “Takeaway1” but other show empty. Weird thing about this is when I tried to display the entity “Takeaway1” it says ticket with that entity is still open. But I have confirmed there are no Open tickets. There seems to be some correlation to the fact that “Takeaway1” is showing and the others aren’t against the “Ticket is Open” error. Suspecting database corruption during the upgrade to v5
    FORUM.zip (196.4 KB)

Help and guidance in troubleshooting is much appreciated.

Did you run the maintenance tasks under settings program settings?

If you mean “Update Rules” yes I did. Is there anything else that I need to do ?