V5 Licence Activation issue after reboot

No reason to wait. Just logout now maybe it wont deactivate.

@clazo91 I’ll PM a link to 5.1.60. If possible can you test that with that version? Please create a backup before installing 5.1.60 so you can revert to 5.1.59 if needed.

Tried but seems not working as well…

Are you always using teamviewer to activate license? did you tried enabling it on physical terminal?

PS: Can you create a secondary sambamarket account and tell me the new user name? I’ll move your V5 license to a new account to test if it makes any difference.

I use TeamViewer mainly to to maintenance from home and as screen capture. for the rest the pc are used every day phisically :slight_smile:

Also i have another branch for my restaurant, the sambamarket username is CladZo91Kumeu and i have the same problem there as well.

I just registered the new account: ThatsAmoreCBD

Even after upgrade to V5.1.60 I still got the same issue…

The upgrade was on CladZo91Kumeu, because CladZo91’s Pc went off and i’m not at the restaurant now!

Do you have management studio? can you edit tables or Execute SQL script on Database?

I wonder if it was always doing that or started recently? Can you guess for how long does it happening?

i do have management studio, I believe i do have access to the tables and if i’m guided i can execute scripts ( but I don’t speak SQL :slight_smile: )

It has been behaving like this since the beginning of the upgrade to V5. my solution was to never log out and never turn off the PC during shift :slight_smile: so It didn’t impact the workflow much.

i have same issue ver4 i posted my problem but nothing worked , every morning we activate both terminals and go through the day and have to do same next morning .i am using version 4 and have a thread on this about 7 weeks old .sorry i can not be any help.

1 Like

I believe emre fixed the problem with V5.1.60,
Try to upgrade to it!

1 Like

Can you confirm if V5.1.60 fixes this. I also have same problem and my system was also an upgrade from v4

1 Like

Hello Jay007,
Emre gave me 2 different builds of 5.1.60 the second one worked which is the one released, I think.

Hi all,

I’ve been having this exact same problem for quite some time. Even after updating to 5.1.60, the issue still remains. Funny thing is there doesnt seem to be a fixed cause or reason the software get auto unregistered. Sometimes it happens after a few days or weeks, sometimes it occurs every day and not always when the system restarts; it happens sometime while in use.

I’ve tried activating and logging out.
I’ve tried upgrading to 5.1.60
Problem still persists.

My setup is as follows: System1: MSSQL DB + Samba POS 1(server)
System2: Linked to MSSQL DB in System1 + Samba POS 2 (Pos2)

Worse part is that when POS1 gets Deregistered, same thing appears on POS2 and only when i Uninstall the license, shutdown Samba, restart samba, Refresh license key from web, log into Samba market on POS1, Install & activate, restart Samba then only it’ll work. After which i have to restart Samba in POS2 as well.

Any assistance on this will be greatly appreciated

@narmeet can you create a database backup and PM me the zip file?

Here I’m again for Licence-related problem.

Since it happens apparently randomly only on PC restart on RDP user login, it doesn’t impact the workflow much.

To fix the problem i log off sambamarket, log off all rdp users but one, restart sambapos, clear licence keys and log back in sambamarket. Then log back in the other rdp users
After restart:

On the first RDP user i get a “Not Valid Licence Found” message when trying to open the POS and the red Unregistered Trial insn’t present beside the Sambapos Logo.
On the Samba market i’m logged in, the Activate button is greyed-out, there is red “working in trial mode. Please Activate.”

On the second RDP i get the Red Unregistered Trial beside the logo, POS is accessible and on the Sambamarket the situation is same as the first one.

Also the HH and VIP system doesn’t work even if i trigger it manually. Maybe isn’t related but might help.

I already made a Backup trough SQL Management studio if needed i can PM it.


  • Install V5 License on RDP Terminals for all different windows users you have to access RDP Sessions.
  • Disable automatic backups and Backup Manually until next update (.61). If you need to have automatic backups try backing up to a local drive or disable “manage licenses” option on backup settings.

Hi @emre i cant activate my SambaPOS too. I have the version 5.1.61
when i use samba without sql server i can activate but if i am connected to the sql server its not working… you can help me please? …

Your license keys stored in Database so when you change your database you need to Clear License keys on sambamarket.com website and reactivate V5 License Module.

  1. Update your database connection, test if it connected fine & Shutdown SambaPOS.
  2. Visit sambamarket.com > My Products page & clear license keys.
  3. Restart SambaPOS.
  4. Login & Activate V5 License module.

ok thank you! it works!

Hi, Im using Samba POS version 5, i have clear license key more than 3 times for each time error “you have modules that need to be activated”. It will long lasting maximum 2 weeks and minumum 3 days before the error prompt again and i have to do the activation again and again. please advise what is the permanent solution to get rid of this issue.

Do you use training mode? There were issues with the database duplication that this entails causing licence issues before.
Its an oddity, I manage 5 systems daily locally for clients who have not needed reactivation since install, one it about 3 years live now.
Id suggest a clean sweep for licence/module;
Uninstall licence module on all terminals.
Close all samba instances.
Clear database key on samba portal.
start samba on main machine
instal module
restart samba
start and install module on all other terminals then restart.

1 Like