What cause the Tip button not to be enabled?

I tried to implement the Tips function following Emre’s method in this thread:

It is working in my R&D machine(single machine) without any error.
When I deploy it to the multi terminals system in my restaurant, it work most of the time but once a while when the cashier reopen a ticket closed at the ordering station(using a different user account), her payment screen will have the Tip button deactivate. What could be the problem?

The button probably isnt set to be active for the state the ticket is in after you have reopened it

But it worked in most cases even when I use the reopen ticket button. This only happen intermittently. Therefore, there should be some more states or such that affects it to be activated or not which I am unaware of.

If in admin login it will show all states. Look at them see what states are not mapped.


I also what to know what does “toggle calculation” means in this screen.

Add/Remove. If no calculation then add. If there is calculation then remove.

1 Like

Could this be the thing then? Under certain circumstances(may be improper designed rule) over reopening a ticket, it puts a calculation there without my knowledge causing the Tip to dysfunction. I will try to un-check this box to see what happens.

Furthermore, I have one more suspicion on the the state of “printed once”, because after I traced the difference between the cashier and order terminal processes vs my testing environment is that they may have printed a bill in between while I NEVER do that step on R&D machine.

This is nothing to do with button enable/visible. There is something interfere with state.

The Tutorial is using a Calculation Selector, so you cannot define the “Enabled States” like you can with an Automation Command.

I guess that Calc Selectors are hard-coded to be enabled only under certain conditions (ie. maybe IsClosed=0 and/or IsLocked=0).

By default, when the Bill is printed, the Ticket will be Locked. Try opening the Ticket, and clicking the Unlock button before going to the Settle screen.

In my setup, I removed the Action that Locks the Ticket for Bill Printing …

1 Like

I think this most likely is the issue. Will test using the R&D system.:wink: