Whozz calling CallerID.com modem working with samba for Caller ID

@emre is very busy making Samba amazing aka he is working on something big. He may respond but he may not. I am looking into it… just might take a bit.

PS luckily I got my new PSU in and I am back on my nice 3 monitor big screen setup :stuck_out_tongue:

I agree with you there i have 4 monitors and I cant stay without them. I got it setup with vmware workstation which is great.


I knew he was on something big because he was releasing multiple versions every month and now its been over a month since he has released a single one.

Im exciteddd!!!

BTW this is not directed at you in paticular @eddhasaj but more so at the entire community or anyone reading this and wondering the question Where has @emre been? I wish he was here to answer my questions.

SambaPOS grows the fastest and @emre can make amazing things faster when the community pitches in and contributes. So if anyone reading this has any ideas or simply thinks they may be able to help @eddhasaj then by all means please contribute and post something. The more people that contribute the faster SambaPOS grows. @emre not being as active on the forums means he is working extremely hard and it should be that way. What I am saying is the more that the community pitches in and contributes the less time @emre has to spend on here and the more time he has to work on SambaPOS making it awesome.

This also means that if more contribution comes in and more ideas get spawned on here then when @emre does sit down and read the forums he gets a larger pool of ideas on which direction to take SambaPOS. If he has to answer all these common questions and things that the community could be answering then its less time for him to make SambaPOS awesome.

Also for those experienced and those that do contribute often it is best to contribute in what interests you so we get more interesting ideas.

Anyway @eddhasaj sorry for the semi Hijack. I am still looking into this for you.

@Hasa Generic modem tested with modems that generates NMBR:xxx formatted data. I tried to open enough configuration to integrate other devices but without working physically with device it is a little hard to understand what the issue might be. Try these…

  • Leave entity type name empty and don’t change singular name Customer to Customers for entity.
  • Don’t enter a baud rate to use default values. Generally port related settings are useful to override defaults.
  • .{32}([^\s]+) pattern seems file as it means (skip 32 chars and read until space). However device might not send data line by line so you need to ensure sambapos can read entire line at once. Try typing new line keyword as termination string.
  • If does not work you may also try \s(\w{3}-\w{3}-\w{4})\s pattern to extract 3-3-4 formatted phone number.
  • Try to handle device event generated rule and display a message box to understand if SambaPOS can read number from device. If it works but not display popup it may mean a entity configuration issue.

Yes these days I’m using my whole time for development and I hope until I’ll be able to have more time for community support it will just keep going on as @Jesse suggested. If you think I have to take specific actions for a better place for community we can talk about it under a separate topic so it will have more visibility.


New line fixed it. Thank you so much!!! @emre looking forward to see what you have been doing with samba :smile: