Will a single terminal plus 2 RDP (android) terminals work with sql Compact database?

i am using sambapos on one pc and plan on connecting 2 android tabs via RDP.
i was just wondering if i could continue using sqlCE or do i have to migrate to sql server?


It will be a better idea to migrate.

@yousufjam, did the database work that I sent you?

it worked perfectly Thanks!

However, after that, due to unrelated issues my sql server is no longer connecting to my database, have tried reinstalling and many other solutions i found online, but not able to install sql server correctly

The issue started after i tried to upgrade to v4 from v3. Is there any way to upgrade the database to v4?

ok i managed to install sql server after 12 hours of trying. i just changed the instance name. for some reason it won’t install using the previous name.

Anyway i have managed to upgrade to V3.0.35 and the database is loaded correctly.

Please could someone tell me the correct procedure to upgrade to the latest v4, I dont want to go through all that again.

This is the easiest way to install SQL Express - http://sambapos.org/wiki/doku.php/en/installing_sql_express_2012_for_sambapos_v3

If everything is working OK with V3, copy your data connection string from Settings->Local Settings and save it somewhere safe.
If you are using V3 Message Server, uninstall the service.

Install the latest V4 version and make sure that it installs into SambaPOS4 directory. You can untick Compact SQL during setup.
If all goes well it should pickup the SQL Express database and convert to V4. Once converted you cannot roll back to V3.
If V4 doesn’t connect to SQL Express, set the data connection string from V3, and include Database=SambaPOS3 on the end. It should look something like this

Data Source=localhost\SAMBAPOS3; User Id=sa; Password=sambapos; Database=SambaPOS3; 

Reinstall V4 and run.

Thanks! all working now.

Only issue I have now is I can’t get message server to work. It is there in the system tray and says “working”
But in Sambapos it says “message server not connected”

Make sure that in Local Settings you have the Message Server name set to your computers name, and that the port is the same as set in Message Server, and also make sure you tick Auto Start Client.
Click Save and restart SambaPOS.

John, you are a star!