Account payment only works once

@emre is there any reason why when I use account payment to pay the ticket, if I then process another sale, adding the customer entity to the ticket that the account button doesn’t work?

I’ve tested with two accounts and it only lets me process one sale using account payment button on payment screen

I then have to settle that account so it’s balance is zero, this then activates the account button on payment screen to process another sale using the account button, then it greys out again and cannot be used until the account is “paid” and is clear again

It does not sound like something happens by default. Can you send me a backup and step by step instructions to reproduce the issue?

@RickH thank you very much for the backup. If you check RickH entity you’ll find an account created but not assigned to entity. That’s why you can’t select Account payment. I tried multiple times but can’t reproduce that situation. I’ll keep trying few other things but please let me know if you find something related.

Edit: Maybe you forgot to remove customer accounts while clearing data?

OK I found your issue.

When balance mode enabled you mean to settle all ticket amount and remaining customer balance with a physical payment method.

Disable it for the default payment screen behavior.


Thanks emre I’ll change that and test again

Do customers accounts clear on the default clear transaction data in samba as that’s what I used

I even manually assigned the account in the entity but couldn’t get account button working but that again is probably to do with balance mode being on

I’ll remove balance mode and test creating entities with accounts again later today, hopefully that’ll sort it

Thanks again

No it only clears transactions but as you don’t have any customers but have few customer accounts I thought you cleared them.

i cleared them and deleted all entities and tried again

The issue is when creating an entity and pressing create account, an account doesnt get created. if i manually add the account in the entity, close samba and reopen the account button now seems to work everytime

so the issue is account not being created when pressing create account

is this the issue?

Should there be something in the Account Name Template field? is this why the account isnt being setup and linked to the entity?

On the backup you sent me it gets created with the loyalty number. While testing try to use loyalty numbers you didn’t used before.

It should use primary field when account name template not defined. So account names will be loyalty numbers.

I’ll try again later with numbers I’ve not used.

So It could be because I’m using the same number even though I deleted the entity, delete accounts and delete all transaction data?

No maybe you deleted entity but forgot to delete account.

I deleted again and did delete the account but still wouldn’t work

I’ll try again with a “new” account number tonight and see if it generates the account

Yep @emre that seems to be the issue, even though i delete accounts and entities and all transaction data, if i then create an entity with the same primary value as one already used (even though deleted) it doesnt correctly assign the account and it needs to be manually added to the entity

i tested creation of a new customer entity with a primary value not used before and it works fine :slight_smile:

1 Like

I don’t know if it worth your time but if you’ll be able to send me the exact state you deleted data and let me know the previously used values I can test why it is happening.

Thanks Emre, message sent

1 Like

Check Account Type Rule… is it set to “Default” ?

1 Like

Hi, thanks for your continuous support.
I cant settle with customer account if bill is lesser than customer account balance.
Account Payment works only when bill amount is equal or more than customer balance.
Balance mode on display payment screen action was set to blank, I

Dont think it should be blank.

I switched to both true and false, still works the same way. Which other area should I look at?
What should be the default setting, false ?

You need to change the setting here to whatever the other option is, False?