All Terminals keep becoming unregistered


#1

Hi I am having a massive issue that has been on going all of last week. I have re registered the license numerous times, including uninstalling the license and restarting the whole machine then restarting the system.

I dont know what to do now as it is becoming a problem with our systems onsite.

any suggestions would be great.


#2

Which version are you using?


#3

Hi Emre,

the version is 5.1.62. I do not have a backup of the older version as I made a mistake of installing a later version and putting it onto the live system which upgraded the database.

I have been on site today for the third time, what I did was disabled the automatic backups on the tills uninstalled the license on each of them and then reset the key. I dont know if this solution will work and it is a concern as they have 6 terminals which all needed to be done together.

is there anything else we can do to be certain it wont happen again as it kept happen after a few hours or a day or so.

thanks


#4

OK. I was about to suggest the same thing. Let’s see if it helps.

Can you create backups manually on the terminal they generally use to end the work period?


#5

it all goes to a server database. can I get it from there?


#6

Sorry I mean, does it create backups without errors when you backup manually on the Database Backups screen?


#7

Hi emre,

I run the backups manually if they are ever required. We run a full system backup every night that does not require any input to the POS system.

When I ran the backup manually it had no errors at all.

We are still having this issue and it is happens once a day. Is there anything we can do about this?

thanks for your help


#8

Hi @emre,

we are still having this activation issue with our tills. It is happening consistently like on a daily basis.

I think the issue could be that we are using too many terminals on this one license as we have 1 server and 7 terminals on site I think this could be causing the issue as I do not know many places that would have this many terminals.

Would it be possible for you to get a similar setup.

If you could help as this is slowing down the restaurant.

Thanks


#9

Licence is per database, number of terminals doesn’t matter.
Which version/update you running?
do you have backup on work period end enabled?
When does it happen? Regular time? Overnight? During day?


#10

We have one database with 7 terminals and it seems to unregister the terminals each day. This issue started to occur when we implemented two new tills into the restaurant. unfortunately when we installed the two new terminals we didnt realise that we put a later version of samba onto them we also never noticed the migrate database option when we installed them. So we have no previous backup of the system to revert to.

We are running the latest version which is 5.1.62 and we run a full system backup every night and also a sql database back up as well. The issue never occurred for the first two weeks so the backups where overwritten.

I stopped the system from taking backups as that was a fix suggestion for this issue.

Any more help or suggestions would be great,

Thanks


#11

[Update] I have two different tests running for our tills. I have taken two tills offline for a few days to see if the other terminals deactivate. If they don’t then that would highlight the issue is too many terminals on a license.

I also requested for them to keep the log on screen up at all times whilst I run these tests as it seems to unregistered when the terminal reboots or they close the software for a moment.

If you have any other ideas I can try then that would be great.


#12

Sambapos supports umlimited terminals per license I highly doubt this is your issue. It’s probably something to do with your backup process. Maybe a setting is wrong?


#13

Hi,

I have disabled all the backup features on the system as recommend from a different post with a similar issue.

After trying them tests I came in this morning with the same issue occuring, unregisted.

I have double checked all systems for any backups that might be running but there is none.

I need to get this issue resolved pretty quick so any other ideas would be great.


#14

Have you unregistered and cleared keys?

I would try that.
Logout market on tills and uninstall licence.
Login on sambamarket.com and clear database keys.
Log back in to market on till and instal and activate licence on terminals.


#15

Hi,

I have already done this. What I did was uninstalled the license of the terminals, then I logged out of the account on each of them. once all terminals where logged out and the software was closed as well as sent the machines for a reboot. I then cleared the database key and then logged re opened the software to reactivate the licenses.

This was done onsite so it took a considerable amount of time, but the positive was it kept them activated for a few days, but takes much longer to perform.

Thanks however the issue is still occurring.


#16

Perhaps use SQL manager to look at ‘program settings table’ And check that there is a database key in there, also only one as did see senario ages ago where somehow they hanaged to get two in the table.which was causing all sorts of issues.
Just to confirm
This is the only install using the licence and all terminals are using the same database right?
Is training mode being used?


#17

I have checked all the terminals and they are all on the same database not a single one is different. I have also checked the training mode and the disable button is grayed out whereas enable is pressable. Which I assume means it is disabled still.

I have checked each till and all the same.

I was unable to find “program settings table” in sql server management studio on 2014, is it in a different location?

I was able to find “programsettingvalues” and that has a key in it. is this what i was suppose to find?

Thanks for your help


#18

that will be the one, yer just one key for the v5 licence would be expected.

There isnt a chance someone has been using training mode without your knowledge and disabling afterwords?


#19

oh wow, imagine… hope this isnt the case


#20

Training mode is only accessible by two accounts and the other admin has never entered the settings page for anything as that isnt there area of work,
@JTRTech This is what the “Programsettingvalues” shows

Is this what it should look like?