Another "can't connect to database with current setting" issue


Sorry to ask about this issue again. I really lost even after searching on the forums.

I have my main POS laptop that use for cashier and have the database installed there.

I use another laptop just to open the SambaPOS to check the sales(tickets).

Previously I’m using ADSL internet and just yesterday I upgraded to Fiber Optic internet, which replace my router/modem. I’ve re - set all the IP Address to like my previous router setting.

  • The main POS laptop works fine and able to do all the transaction perfectly (able to connect to it’s own database)

  • But the issue now is that when I open SambaPOS using my second laptop, it show the connection string error “can’t connect to database with current setting…data source=IBM-THINK\SQLEXPRESS; User Id=sa; Password=sambapos”
    which before I change the router, everything works fine.

  • Both laptop set to Private Network (HOME), one is using Windows XP, the other is Win 8.1
  • Using 2nd laptop I can open the main laptop from windows explorer by typing the computer name: “\IBM-THINK”

Please help, thanks

Hi @singbkt, check your router firewall settings.
Ping from one to other computer to see of you establish connection.

Hi Peter, thanks for the reply. I can ping the 1st laptop:

Hi @singbkt, if you can ping it means your network is ok.
I do believe that there are settings in the router who block some ports needed. Could be port 8080 to open as SQL is using this port. Otherwise just disable the firewall settings if possible and looks of it works. otherwise just connect a separate router for for the POS system.

I think here problem it is in workgroup settings
try see you IBM-THINK your network (explorer)
or try in conection string write IP

Thanks guys for helping to solve my problem.

I have turned off all the firewall setting on the router settings.

I also think it maybe the workgroup setting. I tried to change to\SQLEXPRESS still no luck, the weird thing is that when I ping (the IBM-THINK laptop IP Address), how come in command prompt ping it show and can’t be reach. Also when I ping IBM-THINK the IP Address shown is like weird number?

It does not shows different ip address. As it says Destination host unreachable we can assume is your local IP address. Not another IP.

This is IPV6. I’m not an expert in that area but you can force pinging IPV4 address by adding -4 switch end of ping command. Like ping xxx -4.

1 Like

Hi emre!, oh I see. Thanks for the explanation. Is more clear now.

Hmm… after changing the router things became messy, not only the POS , but my CCTV also. Is it because of the forwarding that happend inside the router?

If the network config is complicating the diagnosis take it our the equasion and check that the host/server/database machine is configured correctly.
Do you have a spare old basic router/switch you could use to connect them? Or you could try direct connection between the two computers and set static IPs as a ‘adhock’ type network. (most network cards are auto switching for crosover I bevel nowdays)
If you have a complex network setup I would want to ensure the database machine is configured properly before messing with network settings and VLans.

Ok… I just tried to change both laptop to connect to the old router, and it worked .

The problem is with my new router. I also tried to use those iPad video app which we can transfer video using web browser from laptop by typing the iPad IP Address, e.g.:

Usually it work flawlessly, but with this router it cannot be opened. Looks like it blocking the port?
I have set my firewall to “Disable”

If you have virtual lans setup are both devices on the same vlan??

An easy solution would be to put the 2 or xx POS systems just on a separate switch and configure the POS systems with there own IP address. To get also Internet access you can connect the switch to the WiFi Router and configure the DNS Servers manually in the Network adapter.

1 Like

Hi JTRTech, sorry , do I have to setup virtual lans? and how to do that?

Hi Peter_Cijsouw, looks like this the only solution for me right now. I just tried to connect my adsl router as Access point but my networking knowledge is so bad, I cannot do it haha. Well do you know what port did SambaPOS use to connect to the database of another laptop?

Pretty sure if I remember right 1433 is the SQL port.

It wasnt a case of setting up VLANS, my question was if you do use VLANS which it looks like your router has some configured how are the defined? by switch port? they may not be configured correctly on the ports used…

What you want to try is the computers with samba completely isolated by the router.
Have the router on its own with only two wires (network cat5) one to each device. then try.
Im pretty sure is your managed switch you showed screen shots of the admin page.

If you wont to be 100% sure, connect a cross over cable from one till to the other till.
Than start trouble shooting and move back to switches or routers.
But first confirm that your 2 till systems can communicate with each other.
And both have set static IP address.

Have done this before but didnt use crossover cable.
Pretty sure most devices are auto switching now days.

You would obviously have to set static IP.
Also as there wouldnt be a DNS you would have to use IP address in the database setting for host computer OR set an entery in the hosts file on the machines to resole the hostnames to their IP addresses.

If you run sql 2014 look here

and set IP4 to your IP address and Enable.

What does that achieve?

Allows outside connections.