[Answered] SambaPOS V4 requires .Net Framework 4.5 [Yes]

Hi. i have instaled SambaPOS V4 on Windows XP. The only problem is minimum requirements for .Net Framework is 4.5 , but not supported by XP.
Any ideas?

1 Like

It will work with .NET 4.0 for WinXP

v3 is working, v4 doesnt.
i have instaled clean v4 and is not working and also i did upgrade from v3.
same error…

Did you install this version if .NET 4.0 http://www.microsoft.com/en-au/download/details.aspx?id=17718

SambaPOS V4 had the dependencies reduced to .NET 4.0 to run on WinXP. Make sure that all available .NET updates have been installed, including SP3 for WinXP.
But since WinXP is past end of life, I strongly suggest you upgrade to Win7.

Win 7 will be dead doon too… and win 8.1 requires less computer than win 7. I am not a win 8.1 fun, but I have to say that win 8.1 works faster than win 7 on the same computer…



Win7 has better support for older computers.

You are fast… here, in CAPONGA city, sunday morning, having breakfast, and you?

12:15AM Monday morning :frowning: after a 12hr 800km day.

what?? 12:15 am, so in a few hours up to work? 800km a day? are you traveling for vacations? or traveling is your work?

Not every day is 800km, it all depends on what breaks and where.
Today (Monday) should be a slow day, so I can sleep in a bit, and get some office work done.

Can you give any more information on the error when running SambaPOS V4 ?

i have instaled win7 now and everything is fine .
i`m sure it was from .Net framework.
was something with SAT. for UI

someone has the same error on Win 7 and posted on forum , after framework upgrade to 4.5 everything was fine , didnt helped me because XP doesnt support 4.5
Got a new computer today and now is working on win7…
still trying to set it up…

I got WinXP running as a virtual to test and got an STA error, but if you ignore the error SambaPOS still works.
Unfortunately .NET 4.0 is now 3 years old, and there is an update to 4.0.3, which is still 2 years old - and this doesn’t fix the error either.

Every effort is being made to support WinXP, but there will come a day when that is not possible due to .NET restrictions.

@emre, can you please see if you can get around this issue.

@JohnS I have to debug it under XP but I don’t think I’ll be able run current visual studio on XP. SambaPOS will catch SambaPOS related errors and display own error message. Since it does not display our error dialog, external libraries or even the XP itself might be the cause of the error.

I think it will be better idea to drop XP support for v4 because I can’t use .net 4.5 features for XP support. This is not a big issue for me now but like you’ve said one day we’ll do it.

1 Like

I agree fully @emre, SambaPOS V4 should not be held back due to a lack of support by .NET for WinXP.
Win7 is a perfect baseline replacement for WinXP.
Win7 mainstream support ends Jan 2015, and extended support ends Jan 2020.
If MS keeps up with .NET releases we should see a new .NET version late this year, which should allow 2 years from now before we may have this issue again.

1 Like

After April 8, 2014, technical assistance for Windows XP will no longer be available from Microsoft, including automatic updates. Microsoft will also stop providing Microsoft Security Essentials for download on Windows XP on this date.

1 Like

I just tried installing V4 on XP and get the same problem. I tried with the first release just to be sure (V4.1.07). It shows:

and it won’t let me install without first downloading and installing .NET Framework 4.5 (which I can’t).

Any suggestions?

As far as I know, support for Windows XP (.NET 4) was discontinued in SambaPOS v4 quite some time ago. It’s time to upgrade.

1 Like

Yeah, I guess I’ll have to do that at some point. Not looking forward to that though…
I was hoping it might be possible to at least run the first release of v4 looking at the replies of JohnS…