Auto logout timer

So I followed this post…

And on one terminal it works fine… But now that I have a second terminal anytime I am on one and say close a ticket it will eventually log out… But if I open and close a ticket on the first terminal then open one from the other terminal and close it only the second terminal logs out the first one just sits on the entity screen. Only thing I can think of is that since I open a ticket on another terminal before the first one has time to logout the timer somehow stops or something so I’m always left with one terminal that doesn’t log out… If I do the same senerio but opposite I get the same results just the first one logs out and the second terminal stay logged in… Any ideas?

You need to use broadcast message action to the computer for it to read and then execute desired action for your use it would be Logout User.

You mean to log out the other terminal when the main one logs out?.. I don’t want it to log out a user if then are in the middle of doing something… Just if it sits idle I want it to log out… There’s a good chance that two people could be on a terminal then one person walks away… I was that terminal to log out but if someone on the other terminal continues to work it won’t log that second terminal out at all.

I actually have the timer start on application screen change.

Ok so now that we know more about your setup you should probably show your rules etc on the pc that is not working. Or just show your setup for resetting the timer perhaps its being triggered and transmitted via message server.

OK give me a second and I’ll screen shot everything… By the way it itsnt one in particular that does or doesn’t work… Which ever was the last to get touched works fine… It’s the other terminal that never gets logged out…

you can simplify screenshots by pressing print screen button and then paste it in here.

Where is the rule that cancels the logout?

I don’t think I have a cancel logout rule…

It definitely only logs out on the last terminal that someone was using… So is samba setup to olny start the countdown on the last terminal that was used and that’s why it’s only applying the rule to it?

No it should run that locally on each terminal. Something is interfering with it.

Can I PM you my database so that you can take a look.Im not sure where to look. Or what I should be looking for.

Why not set it up to auto log out every time they send an order? So it returns to the login screen automatically when they walk away from the screen?

I’ve tried that… They say it slows them down when they have multiple orders to put in. They just want it to timeout after a set time so if they don’t manually logout like they should it will auto logout after 2min.

I do have a custom entity screen with the ticket Lister widget setup so that it auto refreshes… I wonder if that is causing it the keep from auto logout. I’ve gone through everything and I can’t make heads or tails of what could be keeping it from working. It definitely has something to do with the rule not running when another terminal is being used… Only runs the auto logout on the last terminal that is used.

The auto log out button is set to log out when a table is closed or when you print bill. I would think it would be something to changing the rules and actions (look under automations) to not log out when a certain button is pressed but after x amount of minutes of inactivity. I’m interested in doing this myself so I’m hoping I can point you in the right direction. Ill play around with it and if I figure anything out I’ll comment back in the mean time I hope I was able to help at least some.

There is no inactivity timer. You have to automate an Execute Automation Command with a delay. You then use the same action in a rule to cancel it like for example if new ticket is created. Or application screen changed.

1 Like

So I have tried many differnt things and im pulling my hair out now… Basically this works… if only one terminal is being used… Maybe I have explained it wrong.

First thing…

If I log into one terminal and dont open a ticket after 120 seconds samba will auto logout… if I open a ticket on that same terminal it will not log out which is how i want it. After i close the ticket i was in it will auto log out after 120 seconds. This is the default behavior I want for all terminals.


If I log into samaba on two pcs and start to work… the only pc that auto logs out is the last one that was touched…
So say I log into two terminals and dont do anything… I just leave it sitting on a entity screen… the only terminal that will auto log out is the last one that was touched. I cannot figure out why this is happening if its supposed to process the rule on each terminal. The first one seems to just not run the rule at all because the second terminal runs it. Id really like some help to better understand what im missing.

Try this: Go to each terminal and the rules for your auto logout set your mapping for that specific terminal.

Tried that… Actually I had to create rules for each terminal and change the Setting name for each terminal that stores the time. My guess is that that setting was just storing the time on the last terminal that used that rule.