Caller ID issue with CTI Meteor Plus?


#1

Hi all,

I’ve implemented SambaPOS v5 at our takeaway, and all is running smoothly. However I have seem to have come up a cropper with the Caller ID implementation. I’ve installed the Caller ID module on SambaPOS.

I have an old CTI Meteor Plus unit which I’ve connected via a Serial to USB adapter, which has set up a virtual COM port (COM5, Baud rate 1200). I’ve tested the unit with Putty and get the following info:

scr_008

Putty can pull the number through as shown. I’ve set up the device in SambaPOS as a generic modem with COM5 as the port and 1200 as the baud rate. However I get no pop-up? Any idea why this would be? I’m guessing I have to trim some characters from the serial input, but how would I do that?


#2

#3

I’ve followed all this info to no avail! Still no luck.


#4

There are tons of posts on this if you use search. Your best bet while you wait for an answer here is to use search. To get a better response here you need to provide more detailed screenshots of the setup.

I personally have not used caller ID so other than using search I won’t be able to help much.


#5

I’ve read pretty much every topic on this via search before posting, but I can’t seem to find the answer.

The above screen is my device setup.


#6

You need to fill in the Entity Type name and entity screen name etc.


#7

There is a device type of “CTI Comet USB Caller ID”, did you try using that first instead of “Generic Modem”?

image


#8

I’ve tried using CTI Comet USB Caller ID with the same settings but again it results in no popup.

@kendash I’ve filled all this in, but it makes no difference. If I use the test function, it prepopulates the data in the right area anyway without any input.

Just proving a little frustrating because Putty picks up the number no problem. I must be doing something wrong on the settings in SambaPOS?


#9

I don’t know about caller ids but generally serial to usb adapters can be a right pain in my experience in print shop using older serial fed vinyl cutters…
TBH could you not look at a different device? The USB caller device I bought a while back was only like £15 and wored straight away.


#10

I did have an ARTECH USB Caller ID unit, but SambaPOS doesn’t work well with that unit, even following the workaround technique I found on this forum. (I.e. running the CHC program and emulating a port).

I then bought the recommended TRIXES unit from the original tutorial, and that didn’t even have Caller ID built in much to my frustration! It also had some terrible reviews with unreliability.

The CTI unit (supposed to be one of the best units out there, albeit in serial form) is actually working perfectly, as I’ve mentioned Putty is picking up the number no problem. However I can’t see why SambaPOS isn’t picking up the data?


#11

Fill in the Entity screen as well. And try giving the popup a name


#12

Just tried filling all relevant fields including Entity screen, etc. No difference! Really stumped :tired_face:


#13

Com braud rate seems very low, is that definitely correct?


#14

Are you restarting samba after closing putty. You can only connect to a port from one app at a time.


#15

Yes the baud rate is definitely correct as that’s what Crucible (the manufacturer) says the device operates on. If you use any other baud rate, you get a garbled output.

Also, I always restart SambaPOS after using Putty, as you can’t obviously simultaneously connect both applications. You just get the Access denied to COM5 in Samba if Putty is open.


#16

Ok I’ve finally managed to find a post similar to the problem, and it seems all it boils down to is the match pattern. So I’ve tried putting in the suggested match pattern of [^0-9]*?([0-9]+)

This finally ellicits a response from an incoming call! But not the one I want as you can see in the following screenshot:

scr_012

And just to remind you of the Putty output:

scr_013

So as you can see, Samba is pulling the matching numbers… but in separate popups, including the initial date stamp.

So, my question is, any ideas on the match pattern I should use to pluck out the number?


#17

Were you able to get the “Test” to function when you highlight the generic modem?

What is the standard telephone format in your country?


#18

Yes, the standard test box for the generic modem works. The number format is a UK BT standard 11 digit number.


#19

I hate to be a pest, but as everything else is working perfectly, it just seems a shame I can’t seem to solve this problem? Perhaps I can fumble my way through solving it, but can anyone point me towards the syntax that can be used in Match Pattern field? My business is completely dependent on Caller ID working, and it seems that everything is in place for it to work.


#20

Try this pattern:[^0-9]*?([0-9]+)\^UOFF-LINE

Or [^0-9]*?([0-9]+)

Try typing new line keyword as termination string.