Can not close ticket please help

Very strange. It does not look correct.

Post shots of your Ticket Type, including the selected Entity Types, similar to this:

Ticket type

Looks fine.

Are you running Local DB or SQL Express? Show your Connection String.

Maybe try reinstall. Re-run the SambaPOS Setup as Administrator.

It SQL Express 2012
Data Source=Gap\SAMBAPOS3; Database=SambaPOS5;

Will try to reinstall

I Install sambapos as admin still not woking :cry:

Is your license installed and activated?

Do you have more than 500 Tickets?

Did you review the following post for migrating from V4 to V5?

Yes it activated. Im not sure about ticket. where can I look for that ??? Yes I follow that post to migrate database from V4 to V5

For Information:
I had exact same issue. when I manually added some rules which was used in version 4. I am also migrating from version 4 but I have started from scratch on version 5 and adding the rules manually. I was unable to pin point what caused the issue as I have checked all the steps, at the end I gave up and restored the backup database (before adding any rules). I’ll make a another attempt. please note, license was installed and activated and my tickets was less then 500.

I had this problem… If I remember correctly it was because I had my “Tables” and “Customer” Entities set to “Sales Accounts”… Should be blank

1 Like

@neo_classic2004 Can you PM me a copy of your database I have time to take a look.

1 Like

@Jesse sorry I just got home will send you my database .:sweat:

@Chipwagon my Table and Customer are blank :worried:

Thank you very much for looking that @Jesse. Please let me know if I need to see that.

Im probably missing something but the rule debugger looks to be firing Close Ticket automation command but nothing after that…
Have you changed the Close Ticket Rule/Mapping;

If this was changed it wouldnt get to the before ticket closing event etc as the ticket close is not being initiated…

All of his screenshots of his Rules appear to be default, unaltered Rules. They should work just fine. But I agree, the Rule Debugger is indicating otherwise. His output from the Debugger is not correct, and some Events are not firing.

I could understand there being potential problems in the Settle/Payment Screen if something was set up wrong, but the fact that the simple Close button on the Ticket does not work is baffling, because all of his Rules look just fine.

The first thing to do is to get the Close button working, then go from there. It is dead-simple, so I can’t understand why it isn’t working.

Once the Close button works, I will bet the Settle screen works as well.

@neo_classic2004, how large is the ZIP backup? If it isn’t too big, I wouldn’t mind taking a look at it as well.

I thought settle worked fine… is why I said about the close ticket automation command executed rule…
Didnt see that rule shown.

Settle doesn’t work fine. The Ticket remains on-screen even after full payment. It does not close.

There are only 2 Rules that come into play for Close button:

Close Ticket Rule (Event: Automation Command Executed)
Ticket Closing Rule (Event: Ticket Closing)

From his debugger output, it appears the first Rule is firing. But the second one is not. And because it is not, the Ticket and Entity States are not being set.

1 Like

@neo_classic2004, show the configuration including the Mapping for the Close button. It is an Automation Command (not the Rule).

This is my close button and mapping

also PM you database :sweat_smile:

I never got the pm did you send it?

Never mind I got it forum just didn’t notify me. Weird

I won’t be able to look at it until later.