Can we use Sambapos4 on android or apple tablets?

Dear Mr. Emre,

Can we use sambapos4 on pda devices such as ipad or samsung tablets?
And could you please show us how if Sambapos4 supports this option?

1 Like

We’re using RDP clients to run SambaPOS on tablets. You can use 2x RDP client to connect to PC and run SambaPOS. Search for RDP keyword and you’ll find a lot of info.

Pocket Cloud Application from the App Store its free and works a treat.

when using 2xRDP to connect to the PC, can the PC still work on its own? also what should i type in the server for 2x client?


You need to enable Remote Desktop (below is for Windows 7)

Then configure RDP connection. See seteps on below link…

No, PC will not work on its own, because you are remotely connecting to the PC.

Adding a New Standard RDP Connection

1 Like

To run multiple concurrent RDP sessions you need to enable terminal services which for Win7 is a hack.

and for win 8.1??

I found that the home version does not allow multiple concurrent rdp sessions… so for me… is a no no… sad, becuase i wanted to sit down drinking a caipirinha while adding items to tickets, jajajajajajajajajajaja, will have to find another way to do that!!!


Haven’t even tried Win8 yet.

Update - Seems to be hit and miss on Win8 at the moment.
Home editions never supported RDP.

they do… I tested it… but only one session, I mean, if you use RDP on your desktop screen you will see the rdp session…



I dont know if i can do that…

I have tested multiple concurrent RDP sessions Universal Termsrv.dll Patch and it does the trick… thanks John.

I have used Windows 7 Pro O/S as main system and connected from a Windows 8 system. and it works…

Two Windows user accounts was created on Windows 7 systems (main), had one user account logged in with SMBAPOS running .

From Windows 8 system RDP into Windows 7 system and logged using second user account. run SAMPOS and it worked- multiple concurrent RDP sessions.

RDP sessions limitation can be bypassed by applying an unofficial modification called the Universal Termsrv.dll Patch, which is provided by a developer who goes by the handle DeepXW:

Download the Universal Termsrv.dll Patch and extract the ZIP file.

(Download link is deleted, because suspected of being infected - Please search another site this file. File Name is UniversalTermsrvPatch)

Find the patch program you should run based upon your processor. For 32-bit (x86) it’s UniversalTermsrvPatch-x86.exe and for 64-bit (amd64) it’s UniversalTermsrvPatch-x64.exe.

NOTE: While the patch program will automatically create a backup of the Termsrv.dll file, to be cautious you can manually save a copy yourself. You’ll find the file at \Windows\System32, and to undo the Registry changes it makes, you can save the .reg file that’s included with the download and manually edit the Registry to remove the changes shown in the .reg file. For Windows XP you’ll want to save the xp.reg file, and for Windows Vista and 7 its vista.reg.

  1. Right-click on the patch program and select to Run as administrator.

  2. On the program, click the Patch button and it will replace the Termsrv.dll file and perform the Registry modification. It will also save a backup so you can later undo the modification if desired.

  3. Next, restart your computer for the modification to take effect.

Now you just need to enable incoming remote desktop connections. Here’s how to do so with Windows Vista or Windows 7:

1.Right-click on Computer from the Start Menu and select Properties.

  1. Click Remote settings on the left.
  2. Under Remote Desktop, select one of the three options.
  3. Administrators on the computer will automatically be added to the list of remote users, but if you need to add standard users, click Select Users.

Windows should automatically configure Windows Firewall to allow the RDP traffic to pass through, but if you have a third-party firewall installed on the PC, you may have to manually configure it to allow the traffic.

As with normal remote desktop connections, remember that to remotely connect over the Internet you must configure your router to forward incoming RDP connections to the desired PC. And unless you perform other RDP settings modifications to change the RDP ports in the Windows Registry you’re basically limited to configuring one PC on the network for incoming connections via the Internet.

Later i’ll create a simple step by step tutorial for others to follow .


1 Like

If you are using Terminal Names within SambaPOS - ie Terminal specific menus, etc, you need to make sure that you move the SambaSettings.txt file to the user path for SambaPOS for each RDP user. This is typically C:\Users\{user profile}\AppData\Roaming\SambaPOS\SambaPOS4
If you don not do this, all RDP users will have the same Terminal Name.

You can file the App Path & User Path in Manage->Settings->Local Settings.

@gerlandog, what I meant to say was that Home Editions do not do traditional RDP, and they lack a lot of network support that Pro Editions have.
Home Edition is only for home users. Yes it will work, but when you have issues with networked printers, or workstations loosing the server - its because its Home Edition.
Win7 Pro 32bit has been the best solution for all my setups.
I have Win8 on my Tablet & Win8 Pro on my laptop, and have had no issues at all with running SambaPOS.

This one works on Win8.0 Pro - here. Supports 8.1

info for noob like me…i figure out the 2x client, failed to use computer name to connect, connected via ip address by going run->cmd->ipconfig
then the username and password is exactly as your windows user account details.

to use ur computer simutaneously you can create another user account and log into that

iPads (Apple devices) seem to hate Windows computer (NETBIOS) names.
Set a static IP address on the RDP server (so a restart doesn’t set a new IP address), and connect using IP address instead of server name.

thanks. when it enable multiple user …does it work on one user account or need to create multiple user account?

another funny thing. on my one laptop, one user account connect successfully while the other saying connection denied beause user account is not authorized for remote login where i did allow it

You need a User Account for each RDP device.
To set users to access RDP, go to Control Panel, System, Remote Settings, Select Users.

1 Like

i have taken all the information and created a step by step guide for other people. Thanks all

that’s useful. might include what shall we put in the server name, user and password in the 2xRDP apps as initially i thought it’s the sa and sambapos. took a while for me to figure out it’s actually requesting for windows user account. i am to dumb haha.

anyway, i have sorted my issue. (on window 8) patch etc all tested and working perfectly. Thanks for the support guys