Can't connect laptop to server HELP!

I have an issue with my laptop connecting to the server. I’ve reinstalled the Samba software and I still can’t get to the main screen to configure the connection string. It keeps giving me the same error 26 - Error locating server/instance specified.
The only way I can run the software is using Team Viewer remotely from my laptop. Please advice as to what to do.

Error locating server/instance specified. seems pretty self explanitory to me.
Check you server firewall, maybe test by disabling for a moment.
Do you have any other terminals?
Can you ping the server from the laptop?

Do you install SQL server Express on server?
What is database connection string on your laptop?

Hi! I am having the same problem. I checked all the connection strings and turned off the firewall, but still nothing. What do you recommend I try on the server?

You need to to do a few things.

Firstly if you JUST setup SQL Express and SambaPOS by default and tried to access remotely it will not work.
You need to enable TCP/IP in SQL Configuration Manager and set a port.
Then create a firewall rule to allow the specific port to run through firewall(this allows firewall to be active)

Then if your laptop or device on the same network, you have to first ping the server computer to ensure you can talk to it.
Then in SambaPOS(On client device I.E. Laptop) change the Database string to IP address. E.G
Database is located on,4910
^Ip ^ Port of Server
of server
if connection is successful then its connected and thats it.

IF your server computer cannot connect to SQL Database then,
Go ensure the SQL Database service is running by checking Services.msc, it should show status as “Running” If not, you can right click and press “Start” or if it is running, click “Restart” and then…
Check SQL Management studio to see if you can access Database from there, if you can then you should be able to access database in sambapos also.

If second method make ur DB work, then you can try First method to setup Database to work on client/remote clients.

I have checked all the settings on the server and they are set as recommended by the setup documentation. However, the client/laptop has the latest SambaPOS program installed. But the problem is that the program does not let me check the settings because once it starts it shows the error mentioned above and when I click OK the program shuts down. The laptop can connect to the server just fine because I can send to the printer hooked up to it and I can access files on the server in the shared folders. The issue is with Samba on the laptop. I tried uninstalling and reinstalling Samba but, again, I can’t get into the setup.

Go here

You may need to enable “Show Hidden Files and Folders” from folder settings to access “ProgramData” as its a hidden folder in C:/
Delete SambaSettings, restart SambaPOS and that should allow you back into SambaPOS login screen.
From there you need to reconfigure your Database String inside Manage

There is no folder in named Program Data. I did a search for the file and nothing

If you are using windows 7
If you are windows 10

Then search your C: drive

Ok, I deleted the file. I started Samba and I am able to get to the settings now. I entered the settings as per the setup documentation but it still not connecting to the server. And thanks for your time, your help and patience.

Being able to print does not mean its definatly all setup on server ok.
SQL networking requires rules in firewall and ip/pipe settings to be configured.
Install MSSQL managment tool on the laptop and try and connect to sql on server with that…
What are you using for your connection string?
Do you definatly have SQL Express on the server and not LocalDB SQL?

Yes, SQL Express is installed on the server. I pinged the server and got 3ms response. The problem is that it is still not connecting to the Database on the server

Any other suggestions?

Ping confirms they are on same network etc - again doesn’t prove SQL setup is ok.

Have you tested with firewall turned off just to check?

Yes, I’ve tried with both firewall off and on for the server and the laptop. Is there a screenshot I can share with you and see if I have something set wrong?

Did you defiantly enable sa user on SQL, it had to be selected else default is windows auth.

Also what is that screenshot with connection sting? It says successfully updated?

You could try replacing your server hostname with its IP addres encase your having DNS issues on your router/network.

We are lost here. It seems like everything is correct. Is there anyone who is a super Samba expert that would be willing to do a remote session? check it all out? we could pay some via pay pal?

From local database setting screenshot you provide it seem connection is ok. What the error message you got now?

Got the laptop to connect finally, but how do I access the database on the server?
Everything is blank.
Correction: I got to connect to the message server, but I still can´t access the database

The error I am getting is: Connection Error
A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

Mentions named pipes… Have you setup as tutorial?

Message server is seperate service/ports and is not relevant to database connectivity.

What’s all blank?