Can't restore backup - Empty file name is not legal

My system crashed and I lost my settings. The system restored to some bizarre default state. I tried setting everything back.
SambaPos lost all its data. I can login with the default password 1234 and there is no custom data. When I tried to restore the information from a backup I first got the message that SambaPos database is in use by another program. I stopped all instances of sql and now I get this error. What can I do?

reboot to start cos itll start up whatever is needed to get samba up again.

Then once youve sorted that, you really should convert your database to SQL, much easier to work with.

Check out this tutorial:

1 Like

For CE files you can extract zip file and replace database file that located under [My Documents]\SambaPOS5 folder.

It might be a good idea to upgrade to Local DB for better performance and reliability.

1 Like

I migrated the database to SQL Express. Now I can’t backup. Here is the error I get:

What did I do wrong this time? Samba works fine.

Access denied, says it on the message, move the directory or give SQL permissions for the folder.
User/Documents folders have strict permissions, backup to folder in root of c drive or external drive for now.
If you want to use that directory search forum for NT Service\MSSQL$SAMBAPOS for how to give SQL instance permissions to a directory it doesnt already have access to.

1 Like

Ok. I will try directly on C. I didn’t knew SQL had different permissions than the user account under which it is operarting. My understanding of these matters is basic. Thank you for the help.

It’s more to do with the documents folder having special permissions I think, hence why outside documents is generally ok.
Search for the NT service on forum, few posts explaining how to add SQL permissions.

Changing the location of the backup file solved the problem.