Can't Void or Gift with Reason!

Hello, Im driving me crazy with Void or Gift with a Reason. In past months I removed Gift and Void options, but now Im trying to restore them, so I recreated rules, actions, automation commands and estate, I looked in SQL server in a virgin database for strings with gift, void, cancel, etc etc, so I recreated everything to get it working. But I have a problem, when I put some Values in Automation Commands, so the user give a reason for void or gift, it doesn’t work!!, If I press a Reason SAMBA doesn’t apply the gift or the void. However, if I remove the Values (Reasons) from the Automation Command, it works!, What can I do??? thanks in advance

You can show how you set this up.

Show all your Automation Commands, Actions, and Rules with Actions expanded.

Maybe we can export those settings from a virgin db and import into the one you want and see if that works? Possibly the easiest way to do it. But manually doing it helps to learn too :slight_smile:

Thanks for reply QMcKay, Screenshots:

For Gift:

For Void:


From search I found Configuring Gift & Void Reasons
It is emre tutorial for v4 but I think it should work.

Thanks for reply sukasem, I read that post, but it didn’t works for me, it must be there something that I’m missing in the automation command, rule or action, but I cant find it!

Add Show Message Action to Gift Rule to display CommandValue

1 Like

I did what you suggested, but the button doesn’t shows any message, even if showmessage is the number 1 action in the rule, and even if the message is a fixed text: “Test”. So I recreated all rules, actions and automations commands related to it and it doesn’t works, @emre can you check if its a bug in .62 version?, because I tested a brand new database and the error is there, when you add reasons to Cancel or Gift Commands, they stop working, the reasons buttons doesnt work.

That mean your automation never fired. So check if the name correct.
Or replace [:CommandValue] with some word. If show message still not show up then the rule was not fired

1 Like

Yes, I even did that, but it doesnt work, but if you remove the values (reasons) from the command, the button works!, even in a completely new database. Im using last version .62 with sql server express

Maybe bugs then. I will try to recreate it.

Thanks so much sukasem!

It works for me but I’m using Mar 17 version not the latest one.

@emre Mine is from April 11, so I should wait if it’s a bug, thanks again sukasem!

This is release 2017-04-11 and it works fine for Void and for Gift:



Ooops is not a bug!, my commands, actions and rules are the same as yours, actually I copied them from a virgin database, now I can’t figure out whats the problem, maybe some fields corrupted in my database?

You say even default database have problem?
I don’t know if Language issue? Maybe try install English version.

This is not a language issue. Tested with default Spanish version and it seems working fine.

:disappointed_relieved:I’ll try in a different terminal, thank you so much for your help!

I dont know what happened to my Samba, but I unninstalled it and the reinstalled .62 version and now it works!

1 Like