CAS ERJr connection

Hi every body ,
Is my first post on thr form and I think it will not be the last .
I just purchased Pos and I found SambaPos not that bad to implemented for one of my client . ( I’m using for the moment the trila version to check the viability of the product and is look wonderful)
so I went all around with issue based on that forum that was very helpfull , but I got stuck now with the scale weight integration.
1- I have CAS ER Jr scale and I followed all the procedurefor local settings…device …etc COM…see attached.


2- I used Putty to check if the scale with communicating with the PC and went fine as describe ( see attached )
image
3- the problem now is that on the main screen the weight of the product doesn’t appear , Is like SambaPOs doesn,t recognise the scale.

I will be happy if anyone can guide me to resolve that issue .

Thank you very much for your help

You have to configure the scale so that it outputs the barcode to the POS.

thank you for your reply how to configure the scale ?
which setting I have to do ?
thanx

Google the make and model of your scale and see if you can find a manual.

I have the manual , nothing is mentioned and I mentioned putty interconnect with it straight ?
are you familiar with this knd of integration ?

Oh I see. You’re following this manual, so you don’t need barcodes then.

Press your Windows Key.
Type “device manager”
Press Enter.
Expand “Ports (COM & LPT)”
Find your CAS scale and see which COM port it’s using.

I know which port is connected to …as explained previously I have right connection with the scale checked by Putty program please see above screen shot.
The problem is that Samba doesn’t display the weight .

Thats really odd. I haven’t messed with scales and it seems like you have everything set correctly. I’m assuming you aren’t running Putty the same time SambaPOS is open. If not, close Putty down and logout/login of Samba.

Also make sure you have the Scale Module enabled.

ok , I reset new product and is finaly showing figures BUT … ! the object I put weight 0.5 kg and is showing 0.000?

Can you post a new Putty screen with the output and the connection settings.

image

Right. I was talking about the Putty connection settings, but I’m assuming its on COM1 based on the header. I know you need a product multiplier of 1000, but I’m not sure that would cause issues from it displaying the weight in the keyboard. Check out

already checked that … it might a decimal problem or whatever else…
I,m digging on it …
thanx

finally is working :wink:


Nice. It seems like that shouldn’t be needed if you’re using the Case ER Jr and not another type of scale, since I’m assuming the output pattern is preloaded, but sometimes whatever works is good enough.

that also what I understandood … I’m using for the moment trial versionto get use to may be with licencing version it will go straight .
thanx for ur contribution anyway