Common Database Connection Issues - How to resolve them

Wait i try using hostname

It wont work remotely…

It’s working when I’m using hostname

At home?..

At home I’m using wifi too. Using same way as at shop. But didn’t working

need some clarification. is home on same LAN as work?
or do you have server with same hostname at home as at work?

At home, I’m using laptop connect to wifi. Then tablet connect to wifi. Then i change data string same as laptop. But it didn’t work.

is sql instance etc exactly the same?

please screenshot your servers connection sting.

This from laptop

Below from tablet

Ok, but you say it works if you user YOLOKITCHEN-PC ip address rather than hostname?

At the shop it works.

Now at home I’ve got the same error.
Is it problem with sql express? But I don’t think so. I’ve been using with rdp on android with different windows user logon it’s okay.

“Can’t connect to database etc…”

Im struggling to follow to isolate the problem with the jumping from work to home.

Where are you RDPing to? the server?

Rdping is doing good for me. I mean that’s working fine with 2x rdp.

Now I’m trying using windows tablet as a terminal. It should be as simple as just paste the data string on the tablet right? I don’t know where I’m missing. Is it because using laptop just connect through wifi without using lan cable?

The screen shots that i give to u is from home.

I’ve tried changing my ip address still not working. I’ve been following kenda tutorial using sql express 2014 still can’t. Before this i use sql express 2012

The question was what are you RDPing to, the server?

Yes it should be that simple if setup right.

So when does the laptop work at WORK? with IP of server rather than hostname or is that at home?

The laptop didn’t work at WORK. It’s for home ordering. I mean i can just order to home kitchen. It’s not a shop. Just the kitchen is far n we use to have chef at home. So at WORK working fine just simple as paste the data string.

But at home the windows tablet can’t connect to database

Sorry for bad English

The server is the laptop. Sorry missed your question.

So here i want to take order using windows tablet.

Right, so we forget work.
That database connection string on laptop, is connection to a pc server in HOME kitchen?
And that same sting doesn’t work on the tablet at HOME?

At HOME i just use laptop for the server. There’s no pc.

The same string on the laptop, doesn’t work on tablet. Which I don’t know why. The laptop & tablet is connected to home wifi router(with internet).

Then i just paste the same string from laptop right? Is that the right way?

In theory yes.

This brings us back to the original points, the work thing confused matters.

Have you turned the firewall off on the laptop and tested?