Common Database Connection Issues - How to resolve them

I’ve turn off the firewall both on laptop & tablet.

In sql configuration manager I’ve check the protocol for sambapos all enabled.

In sql server management studio, I’ve tested connect to server. All doing fine.

Should i try deleting all sql things then reinstall it back? Where did im missing

You have tried SQLMS from tablet to SQL Instance on laptop?

U mean install sqlexpress on the tablet then make the laptop follow the string from tablet ?

No, install sql managment studio on tablet and check that it can connect to sql instance on laptop.

Am going to hazard a guess kendash got it with the mixed mode auth.

In the mean time double check a ping from table to laptop to be sure they can see eachother

That’s a new thing for me :smile:

i’ll try it

Ping is easy from cmd prompt so try that first.

Then try MSSQL Manager from tablet to connect to laptop SQL.

As I said the more is discussed more I suspect the mixed mode auth as kendash said…

Or try and make a new user on tablet with exact user and pasword as laptop and then try from within that user, or add tablet user to SQL auth list but its much easier just to use mixed mode.

hello JTRTech

i’ve solve the problem.
my tablet can connect to database when i browse for server in sqlms and then select network servers.
here is the photo. i did not try sqlms from tablet so sql instance on laptop.

thanks a lot for spending time to help me

And the problem was?

I just select the network server and it’s working

I dont se how thats solved it… is samba now working on the tablet?

Yes now it’s working

Connecting via SQL manager wouldn’t have fox it itself…
What did you find? What was the problem?

I’m sorry. I think it is just about router problem.
overall i think it is about that.

Hello! Connecting to database server tested with udl file, its OK, but sambapos can’t connect :frowning: Any ideas?

id say your connection string is wrong. Check your instance name is correct.

Post your connection string here

1 Like

Data source=vekonykliens-pc\SAMBAPOS3; User Id=sa; Password=sambapos

The connection string to sql server at the server terminal is OK.

Open Sql Server Configuratin Manager and check the Server Services are running…

If they are, open services (services in the start menu) and check the SQL Server instance is running.

Thats whats needed to connect to the server, windows 10 has a habit of disallowing the user on boot. Might be worth changing it to Delayed Automatic.


1 Like

Sir/Madam (?)! This needs to be in a topic of its own: Firewall Friendly Samba. Thanks a tonne. Much obliged!