CTI Comet USB Caller ID information

Has anyone configured and using the CTI Comet USB Caller ID with sambapos… just need some info how it works (screen capture would be useful) before making the investment…


This video shows how caller id feature works. You can enable English subtitles.

I never tried personally CTI Comet USB device but the user we implemented it for said it works fine.

Thanks… it looks good. l’ll buy CTI Comet USB device and will give it a try…

I just wanted to add that i bought a usb modem which works perfectly fine with sambaPOS for only 9$ canadian.
if anyone here is interested in a cheaper workaround here is the link link to ebay
also if you guys end up buying and cant figure out how to make it work. i can assist you.

@mxood it says it does not support 64 bit windows. Are you using it on 32bit?

This one http://bit.ly/1oTh5p1 supports Win7 64bit. No idea if it’s any good :confused:

I will make sure by tonight.

Ok i checked right now ant it works with windows 8 64-bit and i can also confirm it works with windows 7 32-bit.
also if i someone needs to know if it works with dual lines i could check that too sometime.


Need advise, just taken delivery of CTI COMET USB CALLERID (CTI Comet USB Caller ID (Hardware Only). trying to test…

driver installed (only available driver from supplier site). Device configured to COM17

do i need to configure anything under property editor…

No additional configuration needed.

You can diagnose you caller id with Putty as I’ve described here to make sure it is working properly.

i have tried on two different computer including PUTTY no responce under PUTTY. lost :frowning:

COM3 configuration on 2nd system.

also tried following commends no response…



Didn’t you configure the modem on COM17 ?

COM17 was configured on a laptop. i then carried out same test on a Desktop unit using COM3

I couldnt get to work either. So what i did was download a program(seems like long abandoned but still great) called simple caller id. It searches for the device and tries all the codes itself. You just need to run it once. But note that you need to exit the program afterwards to open the port for samba to use else it will tell you that its occupied. Search simple callerid on google and it should be one of the first few results. Hope it helps

I’ve checked it again and CTI Comet USB does not need initialization. While connecting with Putty set speed to 1200 and it should just work. I mean when you connect it to phone line and call, it should display caller information.

@emre, tried the settings as suggested, still no luck… below is the logs from PUTTY…
i’m also waiting for the phone line company to confirm phone line is actually activated for caller id which may be the issue

2014-03-19 19:31:00 Opening serial device COM17
2014-03-19 19:31:00 Configuring baud rate 1200
2014-03-19 19:31:00 Configuring 8 data bits
2014-03-19 19:31:00 Configuring 1 data bits
2014-03-19 19:31:00 Configuring no parity
2014-03-19 19:31:00 Configuring XON/XOFF flow control

issue appears to be with the CTI Comet USB device. Tst carried out with standard modem (Agree System HDA Modem) and response is logged under puTTY (as per below screen capture). same test carried out with CTI Comet USB and get no response under puTTY.

I have also tried to see if the Agree System HDA modem would work under SAMBPOS by selecting ‘Generic Modem’ under Caller ID device in SAMBAPOS. no response in sambapos when phone was ringing.

You should see something like this when you use a caller id supported modem and line.

After first or second RING it should display caller identification.

@emre, I managed to get the caller CTI Comet USB caller ID device to work.

The driver i used for the device is the driver labelled Windows 8. This driver is also designed for Windows 7


USB serial converter driver installation file for Windows 2000, XP, Server 2003, Vista, Server 2008,
; Windows 7, Server 2008 R2 and Windows 8 (x86 and x64).


The driver i initially used, label’d for Windows 7/Vista/XP Drivers was giving me issue. when analysing the driver inf file it did not mention windows 7 support.

USB serial converter driver installation for Windows 2000, XP, Server 2003, Vista, Server 2008 (x86 and x64).

Signature="$Windows NT$"

i need to clarify following: in SAMBAPOS why does 0 character not detected. the mobile i dialed from start with with 07796… in sambapos caller id pop detects number from 7796. see the result from pUTTY and SAMBPOS caller id pop up. ( i have covered up remaining number on purposes)


Can you try clearing trim chars setting?

1 Like