Email EOD(End of Day) Report Not sending

#1

I’ve been trying to implement the Email EOD report. I’ve set it up to send from one email to another. I’ve created the rules necessary, and yet when I click End Work Period, the I checked the email I want to send it to, and nothing arrives, I checked the outgoing /sent message from the FROM email and there is nothing showing about an email been sent. I Received an error message saying “Can’t send email”

Here is the snapshot of the log

Here is my Send Email Action.


It’s weird because the error states addresses string should not be empty… I checked the settings of the Send Email and besides CC Email nothing else is empty.

Any ideas?
EDIT: I went back to update action. I assumed that ‘addresses’ in the log meant the CC Email address. I therefore filled it with something like [:Email]. It hasn’t provided an error of any sort after closing Work Period, however the email had not been sent or received. hmm,

Email Reports Error(Can not access File)
#2

gmail is notoriously hard to get to work with this action. Outlook mail works great. Gmail can work but you need to be sure your gmail account is setup right for it. Most people ive seen on forum with this error end up just using outlook for their mail.

#3

I’ve got outlook also. I don’t mind giving that a go and see how well it works. I did go and check my Gmail settings to ensure IMAP and POP were enabled and I double checked all GMAIL SMTP settings to ensure they were correct. In the error log it shows that a particular syntax must no be empty. That is what I don’t understand because as far as I can see, the syntax’s are the specific parameter values which must be filled out. The log says the syntax "addresses’ cannot be empty.

#4

The only one for addresses is CC email.

#5

I’ve attempted to try outlook. My settings are below


Now I get this error code

I tried different SMTP port numbers. First tried 587 then tried 25 as per instructed via Microsoft outlook.
Can’t seem to get through. I wondering If this has something to do with windows firewall?

EDIT: I’ve attempted to allow all connections to go through windows firewall for SambaPOS application. Ran Samba under admin privileges, and still returns with the same error code.

#6

Well the error is very specific… it cannot connect to the smtp server. You are following this from Microsoft correctly right?

Use the following settings in your email app.

          Incoming (IMAP) Server
          
              Server address: imap-mail.outlook.com
            
              Port: 993
            
              Encrypted Connection: SSL
            
        
          Outgoing (SMTP) Server
          
              Server address: smtp-mail.outlook.com
            
              Port: 25 (or 587 if 25 is blocked)
            
              Authentication: Yes
            
              Encrypted Connection: TLS
            
        
          User name: Your email address
        
          Password: Your password

You may want to double check your password etc.

BTW its better to use variables in the action and set the actual values in the rule.

For each setting in the action use [:Setting Name] and then set them inside the rule when you insert your action.

#7

I knew what the error message meant. But I assumed by inserting the smtp server address and port into samba, that samba was the acting client of sending emails , which made me assume that you didn’t need an app such as outlook to run for samba to send the email. I’ll go try setting the app and see if that works.

#8

SambaPOS act as a client and does not need outlook. @Jesse suggested it to validate if your settings works fine out of SambaPOS.

1 Like
#9

Ok Inserted all the required information. It logs into incoming server fine using SSL. but sending a message gives me this error using SSL


If I don’t choose any encryption I get this error message

However IF I pick Auto for encryption setting. It goes through successfully

EDIT UPDATE: I may have found the fix. It seems to be working now. But only after I changed the retry count from 5 to 1. That’s weird but anyway.


^^^ Those settings worked for me. After I changed the retry count from 5 to 1. tested 4 times and received email all 4 times.

Weird. Thanks for all the help guys :slightly_smiling:

1 Like
#10

Im surprised outlook still use 25, though most mainstream provides enforced higher security restrictions and the associated ports which seem to go hand in hand with the security.
have 5 accounts on my PC and they all use either 587 or 465.
Anyway, good to see you got it working :slightly_smiling:

#11

Could you please share your rules and action. I would like to set up the same thing in my restaurant as well

#12

I’m pretty sure he did. Did you read the discussion? He posted very detailed screenshots

#13

I don’t have outlook mail account. I have only gmail account.
how can i use EMail EOD?
Guide me,please.

#14

I vaguely remember a conversation about this and gmail, if i remember correcly you cant use gmail, it has some security settings or something thst block samba being used

If im wrong or its changed someone will reply and say, but im pretty sure i read we couldnt use gmail

#15

I am using gmail , just try send an email, the log in to gmail and you should get a popup saying an unsecure app tried to connect to your accout. There should be an option to enable unsecure access. If not then its in the gmail settings under security as far as I remember.

3 Likes
#16

@Jesse Can u please help me out with this issue while sending the end of the day report through mail.
I am using Gmail . And the log file is showing Could not find file. File Not Found Exception…But i have the file in that location.

#17

It’s trying to send it before the file is finished generating. Use execute automation command action with a delay to allow report to generate.

#18

So how to solve it ?

#19

I have created an action called Delay


#20

Still it is not working