Email EOD(End of Day) Report Not sending

Im surprised outlook still use 25, though most mainstream provides enforced higher security restrictions and the associated ports which seem to go hand in hand with the security.
have 5 accounts on my PC and they all use either 587 or 465.
Anyway, good to see you got it working :slightly_smiling:

Could you please share your rules and action. I would like to set up the same thing in my restaurant as well

I’m pretty sure he did. Did you read the discussion? He posted very detailed screenshots

I don’t have outlook mail account. I have only gmail account.
how can i use EMail EOD?
Guide me,please.

I vaguely remember a conversation about this and gmail, if i remember correcly you cant use gmail, it has some security settings or something thst block samba being used

If im wrong or its changed someone will reply and say, but im pretty sure i read we couldnt use gmail

I am using gmail , just try send an email, the log in to gmail and you should get a popup saying an unsecure app tried to connect to your accout. There should be an option to enable unsecure access. If not then its in the gmail settings under security as far as I remember.


@Jesse Can u please help me out with this issue while sending the end of the day report through mail.
I am using Gmail . And the log file is showing Could not find file. File Not Found Exception…But i have the file in that location.

It’s trying to send it before the file is finished generating. Use execute automation command action with a delay to allow report to generate.

So how to solve it ?

I have created an action called Delay

Still it is not working

That’s not how you use it, in the auto command name in your delay action type Send Email and set the delay to 1 for 1 second

Then remove the test email action and save that rule

Now create a new auto command executed rule
Add constraint for auto command equal Send Email

Then add your test email action

That should work, if not set the delay number higher in the other rule as it may take longer than 1 second to complete process before then sending the email command


Thanks Rickh. Let me check it

@RickH Thanks Brother. Its working now .

1 Like

It has nothing to do with that and he resolved it thanks.

1 Like

Hi ,it is working with gmail . Thanks

For next update I added Command Name and Command Value parameters to Save Report to File action so it can execute the command after report gets saved.

Being able to set multiple parameters feature used here so to read these values we can use [:File] and [:Email] parameters from the rule that handles Send Email command.


The email keeps popping the retry error can i get a clarification on the above

Show your rule that sends the email.

1 Like

Solved it thanks to this had to read it twice :slight_smile: