Epson TM-T88V Beep Command

@QMcKay that all seems overly complex. I can’t imagine it would be more complicated on an Epson printer compared to a cheap Chinese one.

Did you try the code I suggested?

I agree. I just posted all the information that I could find in the reference doc.

I haven’t had a chance to try it yet (I have a TM-T88V and a TM-T20II, both of which use the same commands for the buzzer) and I don’t even know if either of my printers have an internal buzzer to begin with. :wink:

1 Like

I tried out some of the commands, but all to no luck.

Tried digging around the Epson drivers themselves, and found that the Advance Printer Driver 5 displays the feature more prominently in the second tab, whilst in APD version 4, the buzzer is hidden under some settings. In both versions of the driver you can get them to work though, through a regular windows print job, however not from POS.

It seems to me that the buzzer (at least in the TM-T88V I have) is the same as the error beep whenever the paper’s out, so probably the TM-T20II has the same type of buzzer. Maybe there is a way to intercept the command that is being sent to the printer (and thus, the buzzer) when performing a normal windows print job. It seems weird that Epson drivers do not handle a Samba print job the same they would do with a Windows print job, even though they both show up in the printer’s digital queue.

I have never heard my Printers make a sound, even when the paper is out. So I need to assume my printers don’t have the buzzer. If that is the case, there is no way for me to confirm any test commands. :frowning:

I just checked with my printers, and they don’t make a sound when the paper’s out, so my bad for the misconception 0:-)

Have you tried using the Advanced Printer Driver 4 with the buzzer enabled before every document. In my case, when printing the windows test page it beeps two times before the document.

This setting is found under (yeah my screenshot is in Dutch, whoops…) Printer Preferences > Document Settings > Option Buzzer > Internal Buzzer.

You should try that, you’ll most likely have a buzzer in your printer. Only challenge now is to get Samba to recreate the command signal sent to the printer.

[EDIT] Zoemer means buzzer, just to be clear xD

This is actually what <BEEP> or <Bnt> commands sends to printer. It refers to ESC B count lenght command.


What @QMcKay suggests should work however he somehow used our old XCT syntax. Try this.


Actually in the past, I tried <BEEP> but it either didn’t work or it may have been I wanted more control over how it beeped.

1 Like

In this case what you need is <Bxy> command. I’m surprised ESC B command never mentioned in EPSON documents. I can’t remember where it is coming from but as far as I know it works fine for Chinese printers.

…and Chinese printers just copy EPSON spec so I’m surprised it wouldn’t work. I’m also surprised EPSON sells printers that don’t beep!

This is not a serious problem for SambaPOS people :slight_smile:


OMG, how did I do that??? I edited all my posts to make corrections… thanks @emre!


Figured that already, tried it with both the old and new syntax. But so far no beeps.

I’m gonna try the commands emre suggested later this afternoon, my printer network is on the fritz right now :’’)

Finally had the chance to get the printers back up and running, but so far the command Emre suggested hasn’t been working. I really wanted to play it safe, and put every command we discussed here in a seperate print job similar to the drawer kick function ( < XCT >27,112,0,25,250) but again, no luck.

However, instead of looking for a needle in a haystack (the correct command), is there a way to let Samba use the default windows printer preferences? I did notice that I can rotate the regular Windows print jobs 180 degrees (since my printer is currently upside down…), and that this is applied by the windows test print perfectly, but Samba still prints the ‘regular way’.

Perhaps I can let Samba take on the windows printing preferences, and the beep will be produced by the Epson driver itself, instead of one of our (so far unfortunately unsuccesful) commands. (And maybe also print upside down)

Are you using “ESC/POS Emulated Printer” as the Printer Type in SambaPOS? For myself, any printer I have ever used on that mode always still follows Windows driver settings, for example paper size, whether cash drawer opens after print automatically, etc.

You can of course always set the Printer Type to “Windows Printer” however you will then lose support for most of the printer formatting tags I believe.

I did in fact try using the ‘Windows Printer’, and all others, but none of them succesfully activate the buzzer or upside down printing. It does do weird things with my printer formatting tags, varying from incredibly small text (raw input) to displaying the formatting tags as normal text.

Looks like we’re going to have to keep looking for a command that works, unless the SambaGods provide us with knowledge to use the windows preferences, whilst keeping the POS formatting tags and such…

[EDIT] This is what it looks like right now with Samba set to ‘Windows Printer’
Note that the short ticket is not rotated, though it should be, that it did beep before printing the test page, but not before printing the Samba ticket.

But the thing is, like I said, it works fine for me and likely many others. So it isn’t really a SambaPOS issue. What you experience with your printer does sound strange. I have many clients using your model and other Epson printers and never heard of any problems.

You should have it set to “ESC/POS Emulated Printer” - this is the correct mode for your printer unless you are planning to use a language not supported by the printer or want finer control over layout, in those cases I suggest “Document Printer”. ESC/POS mode is the only way to use the printer formatting tags since those are actually sending the ESC/POS commands to the printer. “Windows Printer” will give unexpected results. “HTML Printer” can supports HTML formatted so your template needs to use HTML, and likewise if you use “Document Printer” you need to use XAML format in your template.

I have never used anything other than the ESC/POS emulation, so no problems there. However I do find it strange that, after setting everything up to work according to Windows Preferences, the ticket somehow doesn’t seem to follow that course, where the test print page does.

I might look into a cheap external buzzer, and see if that resolves the issue, since it may be easier to command the external port rather than the internal components of the printer.

One thing that I don’t think you mentioned is, how are you connecting the printer to the computer? Is it USB, Parallel or Serial?

Ethernet, since it has to be shared with three terminals simultaneously.
Drawer kick commands work perfectly fine, strangely enough…