Gloria Food Integration - SambaIN app throws an error


I followed all the steps in the tutorials and went to install ’ Online Order application ’
After installation, it didnt load so i tried to run it manually and following error popped up. when i press ok it loads but the screen is blank.

Please help as I am working to a schedule to get this up and running and its tomorrow.

Windows Version is 10


Hello @andrewkap80,

If you can provide Anydesk ID, we can have a look at it.

It looks like you have not purchased a license yet.

Hi Nizam,

I replied the support email with license details and anydesk id

Hi Jesse,

License was purchased on 20th, it shows as inactive in the CP.

Nizam was able to have a look and fix it.

Hi Nizam!

I am having the exact same problem as well.
I have triple checked that all the settings are right.
I have bought a license, but in the cp it says not activated?

If you are able to point me in the general direction of the error I would greatly appreciate it.

Thank you!!

Hello @BCEats,

In the saying ‘‘Is Activated > No’’ doesn’t affect its working.

If you follow below document step by step you will establish the connection;

In case you still encounter any problem, I can check it out for you.

Thank you for the reply Nizam.

I had originally followed the link you had provided, upto Step 4(Although I have omitted setting up the delivery entity screen in step 3.3)

I have now checked four times…and I’m pretty sure that I have followed the setup guide. Should I post screen shots?

Does sambain show green? Screenshots of it maybe would help.


Press “OK”

Is what happens when SambaIN is started.

Sorry! Forgot to press reply on the below message!↓↓↓

Also these are my settings.
Step 1.1)
Win10, SQL 2014
SambaPOS V5 ver5.3.7390.41561

Step 1.2)

Step 2) Omitted(Gloriafood API configuration)

Step 3.1)

Step 3.2.1)

Step 3.2.2)

Step 3.3)
Executed the “Advanced Delivery Screen Setup” under configuration tasks

Step 3.4)

Step 3.5)

Step 3.6)

Step 3.7)

Step 3.8)

Step 3.9) Skipped(Changing Printer Template)

Step 3.10.1)

Step 3.10.2)

Step 3.10.3)

Step 3.10.4)

Step 3.11.1)

Step 3.11.2)

Step 3.11.3)

Step 3.11.4)

Step 4)

I apologize for the loooong list of images…

Are you using latest version of samba in? Try resetting your license keys and activating sambapos again.

Unless the one that is linked on the page is out dated I don’t believe I am? I downloaded it from the tutorial page.(Not at the PC right now so can’t check)

Would that be clearing the license keys?

No that is an old article.

You can find almost everything here

Hi Jesse!
Sorry about the late reply, it was a busy couple days, and didn’t get a chance to work on the POS.

I have cleared the key, but the problem seems to persist…

It does have internet access?

So I just put SambaIN into the firewall exceptions, and the PC has internet access as well, but still the same.

Hi! I’ve tried uninstalling, quintuple checked that settings are correct(unless I’m an idiot…and missed it completely), Made sure that SambaIN is the newest version(atleast the one that is on the link that you had provided me), double checked license, cleared license key, etc. yet, still nothing.

Was there anything else I can try to see if it will work?

Thank you!

Hello @BCEats,

If you PM me your Anydesk ID I can try to have a look at it.