Help setting up a thermal printer? POS-X EVO-RP1

I have a thermal printer from my old POS system. It is the POS-X EVO-RP1 to be exact. My problem is not even with SambaPOS as I can’t get it to work right even in Windows.

I downloaded the correct Windows 7 drivers for it, but when I print smothering, it will only print once. I then have to power off and on the printer to print again. I assume there is an error in the end of the print that bricks the printer. If I install it as a “generic printer”, I can get it to print in Windows and SambaPOS repeatedly, but as it is “generic”, not only is the format on the receipt wrong ($34.5 on the right, the the 2 on the next line), but it loses the drawer pop function.

Anyway, I was hoping that as it is a common printer that somebody may have gotten it working on their setup and would let me know how. Google provided the “generic” solution, but I am hoping for one that works perfectly. :slight_smile: Thanks in advance.

I have used generic in a pintch including drawer kick…

How is it connected? serial, parallel, usb, network?

It is USB, and I tried various ports, just to be safe. And to get the printer to work, I just used the “generic” driver from Windows. The actual driver from the developer doesn’t seem to work on Windows. I is possible something is wrong with the printer itself, but as I can get it to print and I can get the drawer to pop (just not at the same time), I am guessing it is driver related.

How are you opening the drawer atm?

I just turn the key and open it manually. And I am OK with that, even though I would like it to pop. The bigger problem is that the printing is not correct. I am sure it is different for each printer, may just be this brand that is causing the problems.

The drawer pops when I use the actual printer driver, AND it prints perfectly. It just only prints once, then errors out. But I can get it to print multiple times with the “generic”. The official driver works perfectly, other than the fact that it has to be restated after each print. :slight_smile: As, I said, seems like maybe something at the end is making it error out.

Are you printing as windows or ESC/POS in samba?
Do you have any XCT cotes in your temple (maybe wrong code…)
Are you having to restart the computer or the printer?

I tried ESC/POS and “Windows printer”. Both work great (format and drawer) if I remember correctly, but both also error the printer out. I have to restart the PRINTER. When it errors out, even the “paper feed” button on the printer stops working. If I go to print again, the job just sits in queue until I reset the printer. Reminder, this happens in BOTH Windows and SambaPOS. So it is not the fault of the POS.

Yer, sounds like either a driver issue or printer fault to me…

How are you trying to kick the drawer atm (ignoring the restarting the printer? You would need ESC/POS options and a kick XCT code for the printer in the print template.

The drawer pops on it’s own, even in Windows. If I print some text off of “notepad”, it prints and the drawer just pops. Does the same in the POS. Although I am not looking for the drawer to pop on each print (I figured I would tackle that later). I also used the tutorial on these forums to create a “pop drawer” button and it works, but ONLY if I have the printer installed with the official drivers. With the “generic” drivers, the drawer does not pop.

As far as the template, I am just using the one that is already on the POS software. I haven’t gotten to “customizing” it yet. I wanted to just see if it would print first.

Turn your printer off, turn it on and at the same time press and hold the “feed” button. Should print out a settings form. Might identify any problems if you could post that as well.

I’ve had a few printers that cause difficulties, mainly STAR and Toshiba ones connected via USB and having to install USB-COM drivers which are a nightmare…ended up using them as Generic/text only.

Think newer USB ones are much better though.

EDIT: The fact it kicks on every print means it’s sent in windows to “open cash drawer after each print”…can usually find this option in the printer settings (right click printer, go to advanced features).
I always turn this to OFF, then control the printer the exact way I want via samba and XCT codes :slight_smile:

1 Like

Had a look at the official website…doesn’t mention any form of compatbility on any systems on the user manual and the driver e.g. “Windows 7/8.1/10, Linux” etc. Strange

Was it a second hand unit? I always avoid these as they are often from supermarkets or companies who have completely customised their system, they often change the dip switch settings which makes things a nightmare as well.

No, POS-X (I believe) make their own POS system and they sell you the equipment with the POS already installed on them. In this case, the software is expired, but I still have the equipment. I will look at the setting later when I am at work and see if I can indeed turn off the option to pop the drawer on the printer (I think I looked before and didn’t see one). But your hypothesis sounds spot on… That makes perfect sense.

Perhaps, not sure if i’m right yet.
Print the self-diagnostics when you can. Sometimes they have changed the hard settings. Once i could never get my toshiba USB to print. I printed self diagnostics, and it turns out the previous company (who used to supply a massive chain of bed stores) had changed the printer mode to SERIAL only.
Then had to find a manual, find out how to change it back to USB mode, and then it worked.

EDIT: What i’ve noticed with a lot of other people’s epos systems, the creators tend to prefer one brand of printer and just edit the printer to work with their software. Unlike samba, no other software really seems to have a universal way to communicate with printers. I mean just look at the amount of settings we have for printers! Worst come to worse, HTML always does the trick!

1 Like

Do they have any other ports?
The printers I’ve had with USB have not been serial-USB adapter types…
Have had experience with serial-USB adapters on other devices and always had problems.

1 Like

Jumpers would be my sugestion if you had said serial however if it’s serial-USB adaper type drivers/connection do the test print and check braud rate first, that being wrong had do some funky things… :tired_face:

Print diagnostics are as follows:

Firmware version 1.31
Characters ---------------------------42 Char/Line
Codepage 437 (English)---------- Install

Emulation ---------------------------ECS/POS
Print Density ------------------------ Normal
Cutter mode -------------------------Partial Cut
Paper-Low Detection ---------------ON
Interface ----------------------------------USB

Dip SW Information and Device
Auto Cutter --------------------------- Install
Cash Drawer -------------------------Install

Dip-switch 1 ---------------------ON------------OFF
Hexadecimal SW2--------HEXDUMP--------NORMAL

Print Density---------------------SW3-----SW4
Low Power------------------------ON--------ON

Cut Mode-----------------------------SW5
Full Cut----------------------------------ON
Partial Cut-----------------------------OFF

Paper Low Mode---------------------SW8
Do not detect---------------------------OFF

Beep with cutter----------------------------SW1----SW7
1 sec-------------------------------------------OFF------ON
No Beep--------------------------------------OFF------OFF

Not a huge amount of help there… :frowning:

As above…that’s a very small diagnostics print out.

Sometimes its not worth the effort of messing around with used/uncommon printer models. Sell it on eBay and use that money to buy an Epson TM88iv or above. You won’t regret it.

Ok, so I am narrowing it down! So as directed, I shut off the “drawer pop” in the printer settings in Windows… Didn’t solve the problem. I then shut off “paper cut” in the windows printer options and I was able to get the printer to work repeatedly. YAY!

However… I then went into SambaPOS, set the ticket printer to the correct driver and then ESC/POS and it printed, but then errored out. So, now I am guessing there is some code in the Samba portion? Maybe (paper cut)?

If I set it to “Windows Printer” in Samba… I can get ti to repeatably print. But, the format is way off. It prints, but does not look good. The ECS/POS looks perfect.