HELP Setting up Samba Pos on Toshiba STA-10 pos Terminal

Hi @JohnS @emre @sambacommunity

i have recently purchased a Toshiba Sta10 epos terminal and trying to install samba pos on to it.

i am having trouble configuring the pole display. i have tried @JohnS tutorial aswell as @QMcKay.
but still no luck.

please could you help. i have been stuck with this for months now.

You need to determine how to communicate with the Pole Display. So you need to know which Port it is connected to. You claim that it is a serial device, so it must be connected to a COM port (or COM-emulated USB). If your device manager is not giving you any hints (it should though, look around under each section), you can try this until you get a result:

Open a Command Prompt, and type the following commands until something appears on the Display:

echo test1>COM1
echo test2>COM2
echo test3>COM3
echo test4>COM4

It could be on COM57 for all we know, so keep going until you get something.

Further, if you have any type of manual, it should give you ESC/POS commands you can use to configure the Display, but we know nothing about your display other than what it looks like from the picture. Does it have a model number (not the POS, the Display)?

PS: I’ve added the above information to the very beginning of this Tutorial…

1 Like

Hi @QMcKay appreciate your fast response.

the till is a toshiba sta-10, and the pole display is built in.
the display is on com 4, i have tried this but still does not work.
i get text on the display but it is completely different from what should be displayed, they are more like symbols rather than letters.

i have team viewer set up on the till, are you able to log in and have a look at it for me?
if you can that will be very much appreciated as i have been stuck for months now.

please let me know.
thank you.

this link contains some information about the customer display i am using, the connection type etc. might be useful

@DenizAltun you can create an ad topic for people who intereseted on offering professional support services.

thanks @emre, i have done it.

Good to know how you solve the problem. I have it too.