How can I get rid of the connection string error?

I put in a wrong connection string, re-installed V5 but still get the error and Samba V5 won’t start up. And for gods sake I cannot think of any connection string I can put in there.

And I’m really getting tired of these little things that make it miserable installing Samba and SQL.

I can’t get rid of it, I can’t re-install, I can’t uninstall SQL … what the heck?

Search the forum for database string and read some of the topics. Youve changed the database string somewhere and only you will know what it is as it was setup when you setup samba

That said if youve kept it as the default format you shouldbe able to read the topics and work it out

Reinstalling samba wont do anything as the database string is a local setting stored on your PC not in samba so everytime you install it it tries to connect to the string stored on you PC. The only way to reopen that database is to correct the database string

Reading the forum will help as this asked been asked many times and the answer has already been provided, you just need to read up

Hope that helps

Question is … where is it stored so that I can just delete it?

And there are so many questions asked that you can’t even know which is the one concerning me.

The moment you give in the wrong string you’re screwed! Sambapos won’t even start up to correct it or delete it!

You can correct it directly inside the error dialog. Just type the correct one then restart.

File is sambasettings.txt can be found in c:/program data/Sambapos. It’s hidden so enable to see hidden files or folders.

1 Like

Are you searching the forum?
The connection string is firstly stored in a text file called settings something, a search on forum will show you where this is.
Also there would be the field in the popup about connection string which lets you change.
Setting up SQL is well documented just search in the forum.

You likely have one of the following problems;

String is wrong and can’t find the database
Firewall or network issues means client can’t see database
User/pass is wrong and can’t access

Really? I have to search through a zillion answers to come up with nothing. I just renamed the txt files in program data, sambapos and Samba restarted!

Don’t know what’s going to happen tomorrow when I’ll continue to set up V5. If no luck, bye bye SambaPos!

What are you expecting? We volunteer time to help. There are hundreds of detailed tutorials for connection string issues. You could put an ad for paid support in the AD category as well.

PS I spent 5 seconds to type that search and after 2 minutes found 6-7 discussions on the exact same situation. Another 2 minutes to read them.

You can also check tutorials section. Btw if you really do not like Sambapos because you don’t know how to configure a SQL database then cool there is plenty other POS solutions but do not think we will want to help you more by threatening to not use Sambapos it really just sends negative tone and members won’t want to respond to that.


You have given very little info as to what your issue is other tha ‘I changed the connection string and now it doesnt work’.

I have sumarised the most common connection string issues;

But without more info how can we offer sugestions.

Was it working before with SQL express?
Is SQL on this machine or another on the network?
What is your current connection string?
Can you connect with MSSQL Manager?
The list goes on of questions which could be asked.

You have got 3 experianced Samba users replying to your post.
As kendash said what are you expecting us to say? We are trying to help but its hard when all we know is your getting a connection string message which could be many many things without any additional info.
SambaPOS and SQL buth work and are tried and tested meaning that whatever your problem is is user error, we are trying to help but help us to help you…


I don’t threaten anyone, there is so much, too much information that is not relevant to many problems/issues even if you put in the right search term.

BTW, I removed SQL, reinstalled it, renamed the Samba file and even reinstalled Samba.

But it’s impossible that because of a syntax error to connect to SQL you’re locked out of a program.

Just tell me to delete or rename the hidden data file and the problem is solved.

syntax error? you said you had database conection string error?

Whatever you call it. It said connecting string, which is a Syntax error?

Ok, can you show a screenshot?

Any responce to any of my questions?

No need, it’s solved. Well at least this one. SQL can connect to Samba, didn’t put the connection string yet, but maybe I don’t need to as the printer problem might not be able to get solved with Samba and I’ll need to buy another POS program.

Samba connects to SQL rather than visa versa but thats symantics

With no connection string you wont be using SQL Express you probably be using LocalDB which is Lite version of SQL which only supports single/local machine.

What printer problem was that?

1 Like

The printer problem is a Taiwanese issue, a registered Taiwan only dot-matrix printer. For tax purpose. The manufacturer told me that there need to be a program module written in C+ or C++ to connect the POS with the printer. Simple old style printer, no driver, big problem. Even though it’s a COM port printer, even compatible with Epson ESC/POS it won’t work from within Samba.

Oh, and I need to mention I need Chinese BIG5 in Samba.

This is a standardised protocol… you cant be compatable but not compatable…

1 Like

It’s a WinPos printer compatible with Epson … we are not going to split hairs over it.
Anyways, my USB ticket printer, no problem, just works.