How do you clear Editor Widget Value:Setting

Currently using an Editor Widget to enter a Item Code and discovered the Value is only updated after the User presses ENTER!

So my flow is:

  1. Enter an Item Code
    (Make sure User presses Enter)
  2. Press a Automation Command Button to pass the Value Setting {:ItemCode}
  3. Do some processing - add a record/delete a record
  4. Reset Editor Widget Value {:ItemCode} back to BLANK

All works fine except I cannot reset the Value of {:ItemCode} to BLANK in a RULE? When the flow finishes it returns back to the Widget which still has the old value.

Is this by design?

If this is the case then using a Editor Widget we must:
A. Train the Users to press ENTER to update the Widget Value
B. Train the Users to manually DELETE the Widget Value before entering a new Item Code.

Also when working in an Entity Screen it seems we can drop the KEYWORD “SETTING” from {SETTING:x} and just use syntax like {:SomeName}. It that correct?

You should change your action that updates the setting to also delete the setting when it’s done. You could clear it by refreshing the screen however since I’m not sure what your doing that might not be best idea. Possibly refreshing widget cache might work too.

I tried that in a Rule.
Tried making it LOCAL, tried making it GLOBAl and using Delete.
Tried using Refresh CACHE.

The Value inside the Editor Widget remains?

Is there a specific action to do that? I just found Refresh Cache…OK its Refresh Widgets? - Not tried that…

The setting will clear if you use delete. The widget has nothing to do with actual setting value. So now you mean just the cache of the widget value right?

PS if editor widget loses focus it does same thing as press enter.

Yes - I have checked is I use Delete as a status it removes the Record in the dbo. No record exists if it local.
So it just the onscreen value as I am trying to save the User from having to clear an old value?

That is not right I think as If you enter a Value in the Editor Widget - THEN IMMEDIATELY press a Automation Button (lost focus) the Widget retains the old value!

That REALLY confused me for a bit - if you use TAB or Return it uses the current value.

1 Like

What I’m saying is you don’t have to press enter. Simply losing focus will pass the value. Sorry I was responding to your question about having to press enter.

Don’t think so - I can post a GIF, but the steps are:
Enter Widget Value say “123”
Press an Automation button from when you are inside the Widget
No Update.
I assume (and where we may be talking 2 different things) is when I press the Automation Button it loses focus right?

What button? I’m talking about passing value to another widget. Btw it’s hard to really understand without knowing what your doing.

Ok I will drop a GIF… give me a few minutes.

@Jesse see GIF bellow:

When I enter “123” press Enter, THEN press “Add Product to Order” - Good.
When I enter “567” BUT press “Add Product to Order” straight away - Bad.
(The 3rd Popup is after I press ENTER on “567”)

I have a Display Message showing the Value of [:CommandValue] and {:IVProductCode} - which is Local Setting Value for Editor Widget.

I have now tried ACTION:Refresh Widget Cache after I have tried Updating {:IVProductCode} to BLANK but the Value still persists.

11.50pm going to call it a night.

So why are you passing it as a local setting and using a button? Just use Command Name and no local setting pass the Command Value into the rule for Show Message.

I will give example:

@emre I see what he is saying though from my own testing clicking an Automation Button Widget does not drop focus from the Editor Widget as result it will not pass the value forcing you to press Enter on keyboard and then clicking the Button for it to work.


Button does not capture focus for a good reason. So we don’t need to click on edit box to type next value. I think sending enter key with action will work.


Thank you Emre that is what I figured it has been a while since we discussed this feature. So @pauln you should set it up to behave like how its working in my gif above. Pressing enter triggers the command with the command value of what was entered. Label Widget is reading value from local setting and editor widget is updating label widget.

Yes thanks @Jesse (and Emre).

I just used your method in the GIF and since we need a or to trigger the Rule it works fine.
I guess I was looking for the traditional workflow:

Enter Product Code -> 'Is User Happy with Input?" i.e. no Typo’s etc -> Confirm by press Command Button.

This also means I can have Editor Widget but 2+ Command Buttons like “Add Product”, “Delete Product”, “Some Other Action Product” - working off the same Editor Widget.

Even though using the Editor Widget Command Name works really well for say a Cash Counting screen it my case maybe not.

I will investigate Emre’s link and consider maybe adding a Prompt screen like “Do you wish to Add, Delete, OR…, CANCEL” this Product Code.

Thanks for your guidance.

For what your trying to do I would think Task Editor widget and tasks would be better.

I think with @QMcKay summary on proposed Inventory enhancements - I totally agree.
So for the time being I will hone my skills using these Widgets as this was my first foray into building a decent Custom Entity Screen.

You knew it was going to come right :grinning:

1 Like

Ok after all that I forgot to resolve how to we clear the Widget Value for an Editor Widget?

You see @Jesse using your method (using lost focus to trigger Command) means that if you wish to perform a different task YOU MUST clear the Editor Widget Value otherwise you will get another Command being executed?

I have tried ACTION:Refresh Widgets but does not work.
The Value is a Local setting so {:IVProducCode} seems to persist even if I use UPDATE and reset back to BLANK.

Any thoughts?

That was based on old info. You should just press enter and you can keep typing. No need to clear it.

Well you need to clear it if you wish to click on another Widget? (If you have a Automation Command applied)
It may not be an issue as I am currently discovering the Custom Keyboard Widget and this provides most of the functionality I need.

I suppose the “Tick” & “X” are only available in the Menu Editor right?

Also what’s your theory on providing the full “Qwerty Keyboard” touch keys? It takes a lot of space…