How to add a terminal to SambaPOS

feeling ashamed to tell that it looks working now !!! please let me be sure in minute

1 Like

YOu may already know but dont be confused by Message Server saying its not connected that actually is different and has nothing to do with the Database.

This Explains message server.

1 Like

its definitely working…however, the issue will be there when i will disconnect wifi and connect the PCs through network switch

Are they on the same network?

When you connect it to the switch via cable what is your error message? That could be a firewall issue or blocked port etc. Could be a number of things. If its working via wifi but not cabled network then its not a SQL Server issue or a SambaPOS issue it sounds like the switch or something hardware based.

currently (when its working) they are on same wifi. however, there is no internet at my restaurant. so i netwrok PCs through network switch. they connect and can see/access each others files/folders

Read through the common problems post I shared a few posts up. It likely has a fix that will work for you.

fine. let me read through that. however, please help on the other issue…convert CE to SQL. I did as per tutorial however, it gives error

I cant really help if I dont know the error. Can you show that?

i tried on 3 different PCs…same error on all

That is a very old tutorial and is not reliable. instead read this:

1 Like

OK…i will try with this…and will let you know …thanks a lot

Its little more details but its a better way to do it and does not rely on an outdated tool.

Sure…will use this

With the networking issue how did you open the firewall on the server?
Did you specify work and home networks on the rule?
Check that the wired network has not been set to public or unassigned as if there is no gateway or network type not selected this can happen and if your firewall rule is set to work/home only the firewall might be blocking when connected by wire.

i used this and all went well…however, when i selected the newly created database and tried to create a ticket on migrated customer…system threw an error and closed. thats what happens whenever i try a ticket against a customer on newly created database. however, if i revert back to my database which was there before migration…it works OK…but it has no data as data is imported into the newly created database. name of my default data base is SAMBAPOS4 which works ok…name of database created for migrated data is Mydata3…this shows everything from the legaly system, however can process a ticket. screen shots attached below

Was it migrated from an older version? Try going to Settings > Program Settings > Maintenance and click Upgrade Old Rules. See if that helps.

PS When you get one of those errors we have no clue what it means unless you click Details tab and copy the actual error and paste it in here.

1 Like

both are v4.
however, when i converted the sdf file…it didnt create one .sqlce file…rather it created 20 files. if i copy all 20 files in new Query…it doesnt get copied…so i have to copy fewer files. i tried what u suggested [Settings > Program Settings > Maintenance and click Upgrade Old Rules]…however, that options don’t exist. have attached screen shots below