How to buy and activate SambaPOS V5 Pro License?


#1

How to buy and activate SambaPOS V5 Pro license

NOTE: You can buy license from https://sambapos.com/buy or https://b2b.sambapos.com/store or https://sambamarket.com

NOTE: If you purchased license from https://sambapos.com/buy or https://b2b.sambapos.com/store please visit the link for activation details: https://www.sambapos.com/wiki/doku.php/how_to_activate_your_sambapos_license


For sambamarket.com Sales

Outline:

  • Create an account on sambamarket.com
  • Buy SambaPOS V5 Pro license with credit card.
  • Add your sambamarket.com account information to SambaPOS and activate the module.

Step by Step

1.Registering to sambamarket.com

First you should visit http://sambamarket.com/Account/Register

Fill in the required blanks then click on REGISTER button.

Please don’t forget your username and password that you used for registering on sambamarket.com you will use this username and password for activating SambaPOS V5 Pro license.

Now that you have registered to sambamarket.com you can jump to the buying step.

2.Buying SambaPOS V5 Pro License

After registering, you can buy the license from the “Buy” link on the main page or from the “Modules” page.

2.1 Buy from the “Buy” link on main page

After clicking on “Buy” link, you will see the summary and payment screen.
Once you fill in the required fields the process will be completed.

2.2 Buy from the “MODULES” page

You can explore some paid/free modules on this page. You can go to payment page by clicking on the “Buy” button for “SambaPOS V5 License” You can find it at the bottom and the right side.

After filling in the required fields on the payment page, click on the “Pay” button to complete the process.

You can see your licenses by clicking on “MY PRODUCTS” located on the main page.

3.Activating SambaPOS V5 Pro License

After buying the license from sambamarket.com, you should activate your license in the SambaPOS V5 Pro software application.

Start SambaPOS and login. Click on the Samba Market button located on the main page. Click on the Login button located on the top right side. Login with your sambamarket.com username and password.

You will see your username at the top right side. Click on the Activate button located on the SambaPOS V5 License box.

Now you can use SambaPOS V5 Pro unlimited and licensed.


I can't buy the program. It is asking me for a password and I never recieved one that I am aware of
#2

having issues paying. @kendash Please help.


#3

Might be related with the new website. @Tayfun any idea?


#4

thanks kendash. trying to make that purchase legit. tag others that might be able to help. any ideas @emre ?


#5

I get this same error. I need to buy a license ASAP, my new store is held up because of this – and we can’t add terminals. I keep getting the same error as pcdr23…

Any help - take my money, please! lol


#6

It shouldnt be held up… You dont need a v5 linecese to runt he prgoram through production. I’m guessing its something to do with the session data being inaccurate but honestly im not sure


#7

Just want to bump this @emre, I spoke to pcdr23 already about this and I suggested he posted here. He is my client and we setup SambaPOS for him. He still hasn’t been able to buy the license and now is over 500 tickets so using the trial is slowing him down every day in his busy restaurant. He needs the license ASAP but can’t make payment due to this error.

Thanks.


#8

I talked with @Tayfun. He’ll contact you soon.


#9

@luisvarca and @pcdr23. First of all I’m sorry for that issue. We’re working on it but still couldn’t reproduce it. We’ll try to solve it asap and I need your help.

Can you tell me on which exact step you receive that error message? Can you see credit card entry form? Does it happen after entering cc details or does it happen before reaching CC details page?


#10

Emre for me it was after entering my CC info and then clicking to proceed it went to that! Tayfun followed up, everything is good and I was able to purchase. Thanks so much!


#11

Hi I purchased licence, loged in and clicked on activate button , and nothing happend , but the activate button now is gray, can not click on it to activate it and it still say it is in trail mode???


#12

Hello sinisa. Try logging into sambamarket.com website and on my products page click on clear license keys button.


#13

#14

i have a problema with my payment process, i did it but when im trying to start samba pos this


#15

Licence shouldn’t throw an error like that, usually config error, can you copy and paste the error details?


#16

[General Info]

Application: SambaPOS
Version: 5.1.60
Region: en
DB: SQ
Machine: DESKTOP-C1KRO29
User: This Way
Date: 23/09/2016
Time: 12:22 a. m.

User Explanation:

This Way said “”

[Exception Info 1]

Top-level Exception
Type: System.Reflection.TargetInvocationException
Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
Stack Trace: at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
at System.Delegate.DynamicInvokeImpl(Object[] args)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Inner Exception 1
Type: System.InvalidOperationException
Message: Sequence contains more than one element
Source: System.Core
Stack Trace: at System.Linq.Enumerable.SingleOrDefault[TSource](IEnumerable1 source) at System.Data.Entity.Core.Objects.ELinq.ObjectQueryProvider.<GetElementFunction>b__2[TResult](IEnumerable1 sequence)
at System.Data.Entity.Core.Objects.ELinq.ObjectQueryProvider.ExecuteSingle[TResult](IEnumerable1 query, Expression queryRoot) at System.Data.Entity.Core.Objects.ELinq.ObjectQueryProvider.System.Linq.IQueryProvider.Execute[TResult](Expression expression) at System.Linq.Queryable.SingleOrDefault[TSource](IQueryable1 source, Expression1 predicate) at Samba.Infrastructure.Data.SqlData.ReadOnlyEFWorkspace.Single[T](Expression1 predictate, Expression1[] includes) at Samba.Persistance.Data.Dao.Single[T](Expression1 predictate, Expression1[] includes) at Samba.Services.Implementations.MarketModule.AddonService.IsActivated(String key) at Samba.Addon.V5PROLicense.ProLicenseModule.RefreshLicense() at Samba.Addon.V5PROLicense.ProLicenseModule.<Initialize>b__4_0(EventParameters1 x)
at Microsoft.Practices.Prism.Events.EventSubscription1.InvokeAction(Action1 action, TPayload argument)
at Microsoft.Practices.Prism.Events.EventSubscription1.<>c__DisplayClass2.<GetExecutionStrategy>b__0(Object[] arguments) at Microsoft.Practices.Prism.Events.EventBase.InternalPublish(Object[] arguments) at Microsoft.Practices.Prism.Events.CompositePresentationEvent1.Publish(TPayload payload)
at Samba.Presentation.Services.Common.ExtensionMethods.Publish[TEventsubject](TEventsubject eventArgs, String eventTopic, Action expectedAction)


[Assembly Info]

mscorlib, Version=4.0.0.0
Samba.Services, Version=1.0.0.0
Samba.Domain, Version=1.0.0.0
Samba.Infrastructure.Data, Version=1.0.0.0
System.ComponentModel.Composition, Version=4.0.0.0
System.Core, Version=4.0.0.0
PresentationCore, Version=4.0.0.0
DevExpress.Xpf.LayoutControl.v14.1, Version=14.1.13.0
System.Xml, Version=4.0.0.0
DevExpress.Xpf.Grid.v14.1, Version=14.1.13.0
System, Version=4.0.0.0
DevExpress.Xpf.Grid.v14.1.Core, Version=14.1.13.0
WindowsBase, Version=4.0.0.0
System.Xaml, Version=4.0.0.0
PresentationFramework, Version=4.0.0.0
Samba.Infrastructure, Version=1.0.0.0
Microsoft.Practices.Prism, Version=4.0.0.0
System.Runtime.Serialization, Version=4.0.0.0
Microsoft.Practices.Prism.MefExtensions, Version=4.0.0.0
DevExpress.Xpf.Core.v14.1, Version=14.1.13.0
Samba.Presentation.Services, Version=1.0.0.0
System.Windows.Forms, Version=4.0.0.0
System.Drawing, Version=4.0.0.0
Stateless, Version=1.0.0.0
Samba.Persistance, Version=1.0.0.0
PropertyTools, Version=2012.4.14.1
Samba.Localization, Version=1.0.0.0
ReachFramework, Version=4.0.0.0
EntityFramework, Version=6.0.0.0
FluentValidation, Version=3.4.0.0
Omu.ValueInjecter, Version=2.3.0.0
Microsoft.Practices.ServiceLocation, Version=1.0.0.0
Microsoft.CSharp, Version=4.0.0.0


[System Info]

Operating System
-Microsoft Windows 10 Home Single Language
–CodeSet = 1252
–CSDVersion =
–CurrentTimeZone = -420
–FreePhysicalMemory = 4622400
–OSArchitecture = 64 bits
–OSLanguage = 2058
–ServicePackMajorVersion = 0
–ServicePackMinorVersion = 0
–Version = 10.0.14393

Machine
-DESKTOP-C1KRO29
–Manufacturer = HP
–Model = 20-r126la
–TotalPhysicalMemory = 7441367040
–UserName = DESKTOP-C1KRO29\This Way



#17

This I think might be your issue, I hit this when having a prompt function for same value in a chained automation flow I setup for if a value was empty but many posibilities.

Doubting it is licence related, what else have you changed recently?
If this on startup or on login?


#18

yes i just buy like 20 minuts ago, an then i sing up in to the program, after that the error happend…
what i need to do to fix it?
May i need to call the bank to cancel de charge?


#19

Why, you think is a scam?.. There are thousands of people using the software so be assured there is nothing dodgy here…
I myself have at least half a dozen clients using v5 licenced without issue and several dozen on v4 aswell…

The issue strikes me as a custom config issue rather than a licenceing issue but sure other forum regulars will soon chip in.

If it is a licence issue I expect @emre will also post.

Can you confirm if you customised the automation before activating licence?


#20

Its a license issue. I’m driving so cant talk @emre take a look if you can.