How to change the printer size paper

So when I try to print, I get this error:

Not sure how to set the width of the printer to be 62mm which is what size paper is in the printer.

If I remember right you would want to set default page size in printer properties in Windows and select Windows printer type.

So I cant use any fancy formatting then?

What fancy formatting?
Believe HTML will work with Windows printer.

Escpos option uses fixed width font on printer and defined by number of characters for width.

Pretty sure Windows printer uses page size in driver.

Not sure what defines width for HTML printer.

Ok, Ive done this,

And still i get that error message.

I want it to be formmated like this

or with data like this:

@the133448 I see you purchased the QL-570 then

I found the same problem, the printer won’t print from SambaPOS onto continuous feed labels. I tried a few settings in printer settings but couldn’t get it to print. I didn’t look into it further as I don’t use this printer in SambaPOS. Maybe there is a way you can turn off the paper type check?

I think easiest solution is just use die cut labels, not continuous feed. Is that going to be an issue?

You did that using the P-Touch label app that comes with the printer. I don’t think you will be able to generate such format easily from SambaPOS. You can try to play around with HTML printer or Document Printer (the latter having more flexibility) and with some trial and error you might get something you are happy with.

Yeh, I bought a Borther 710nw, didn’t work well with Samba

We discussed this quite a bit before he bought the printer

Do you have QL-710W or QL-720NW ? Don’t think there is a QL-710NW according to Brother.

If you have QL-720NW you can use ESC/POS commands, might give you better options. But if you have QL-710W you’re unfortunately in the same boat here.

1 x 710 and 1 x720 lol. Didn’t know that! Might give it a go

1 Like

I did it with Microsoft Word, I just setup the paper size and went file Print.
Whenever I tried to print in the document printer or HTML printer, I just got some weird dots on the paper,

There seems to be no way of setting the paper size in SAMBA, Like in notepad for example I can just do this

In word I can do the same

The main consensus was that I would be able to get the printer to print labels with forammting, however I might find the labels too expesnive.
I found a seler who will sell me 1 36m roll for $5 so I went and bought the printer

I got a brother label printer to print in samba, but was pre it labels on a roll rather than continuous roll.
And was basic layout, not like yours.
Was a while ago mind.

I can get a basic label, but I dont have enough space on the small label to just use the default formatting.

If I have time I will see if I can get the printer to work in SambaPOS. I only have continuous feed labels left now anyway, all the die cut ones I used up.

On a side note @JTRTech you say you have one of these? Did you know you can buy continuous feed label film (as opposed to label made of paper). It is more expensive, like about 4x the price (double the price for half the length), but I found it is really good for making labels to stick on the hardware I sell. The quality is just same as you would expect of a manufacturer label on the back of a printer or POS terminal and quite durable. You can check the product code for the label film is DK22212.

Thanks a lot, I would love this to work.

@markjw got a picture of an example by any chance?

Sorry, an example of what?

I tihkn he means example of what the labels look like?

1 Like

Here is side by side of paper label (top) and film label (bottom). Not sure if you can really tell the difference much in the photo, I tried to get a bit of reflection on the film one so you can see the material better.

The film one is a little “off-white” colour, compared to the paper one which is pure white. I don’t know how durable the labels will be long term, given they are thermal after all, but they look and feel similar to manufacturer labels.

…and here is the label stuck on a product: