HTML Printer only work with local printer?

I just playing with HTML printer.
I have kitchen printer connect to server. I can set this printer as HTML Printer (It also have share name \\SERVER\Kitchen Printer). When order place on Server, it works fine but if the order place from other terminal, it get printer error “Invalid Printer”.

If I change it back to ESC/POS printer, no printer error.

The other terminal needs to have that share mapped to a printer and then add that printer. The other terminal has no clue where \\SERVER is mapped too.

Yes, it does. It work when I change printer type to ESC/POS. Have no idea why. I can do test print on remote computer to print graphic test page.

What I am saying is on the terminal go to Add new Printer and then add a network printer… Then in SambaPOS select that printer from dropdown instead of using share name.

OK will try that tonight after close

But no Network printer showed in dropdown list.

It is weird. Printer Type ESC/POS and Windows Printer work no Invalid Printer error.


Did you ever find a solution for this? I changed my templates to HTML today for some nicer font, and all hell has broken loose.
I added the mapped printer via windows, yet I still get invalid printer on my 2nd terminal. ESC/POS works fine though.
I noticed, once i change it to esc/pos, do one receipt, then change it back to HTML it works!! But only for a few minutes before it goes back to saying invalid.

I gave up HTML it is too slow for my old printer. I solved that by restart all computers. I was network issue. I don’t know what the problem is but restart do the trick.

1 Like

Is it just the font your using HTML for?
Im pretty sure some printers have command codes for a few built in fonts… the font printed as I understand is within the printer not Samba so might be worth looking in to that as I too find that HTML is often slower and more problematic that going with good old ESC/POS

Yep font, issue is with the default printer font it’s either too small (using J00) or really tall and narrow (using J10).
Fast paced kitchen and the chefs need something easier to read on the go.

Printer is an Epson TM88V (so basically best I could get). Seems to have options for fonts in the settings in windows, but this didn’t change anything in Samba (using ESC/POS). Hence went for HTML.

HTML does seem to be slower for me, but the difference between 1 second and 1.5 seconds doesn’t matter to be honest. I just don’t want mistakes in the kitchen lol.

Will try again with the printer fonts.

As i’m using HTML, I have the same printer installed a second time within Samba as ESC/POS just to kick the cash drawer. This works 100% of the time. Even when the HTML printer says “invalid”, the same printer on samba via esc/pos works! Strange

Sounds like a driver issue if I had to guess.

When it stops working do the jobs show in the print que?

Give me some. I’m using TM88III LOL

1 Like

Absolutely! I have one of these and they are indeed the best IMHO. Fast, fast, FAST and reliable (but expensive). I also have a TM-T20II and it works very good too, but the TM-T88V still kicks it’s ass.

This was going to be my suggestion as well.

Got a TM70II as well :slight_smile:

I assume its something to do with the network…just cant find out where.
I actually originally had a Star TSP100, this was set to HTML and mapped, worked fine. The reason I changed it is because the star can only be set to one of Html or ESC/POS when you install it, so I couldn’t get my cash drawer kicking.
Installed the epsom tm88v, mapped it exactly the same way, however it doesnt seem happy on my 2nd terminal and always comes up as invalid :frowning:

Taking a look at change the printing font via settings and keeping it as ESC/POS rather than fiddling with HTML. However I would still have liked to know the root cause.

I still have problems with network printer sharing maybe once or twice a month. I have to delete printer and add it again. Remote terminal can’t find the printer name. This is not related to HTML

1 Like

Tried changing the printer font, doesn’t seem to change anything. Anyone got any experience ?

Went to printer settings and substituted any printer font with Tahoma…but the same default font still prints.

I have also come across the this issue, where HTML Printer settings will ONLY on local printer. If the Printer is Networked mapped it will not work., following error message is displayed, not ideal as I have spent lot time redesigning my templates for HTML :frowning: if I only known this earlier I would not have spent lot of time using HTML for the Ticket/Kitchen and Voucher templates.

Error message

No Issue when Printer Type set to ESC/POS Emulation Printer using same printer mapped settings.

Install the Printer and driver as a Networked Printer which should create a Local Printer on the computer with a Name local to the computer.

Then use that Local Printer Name in SambaPOS instead of the Network Path.

1 Like

I have tried using Local printer Name in Sambapos (no network path) on the client tablet and its same issue.

Printer details on Client tablet.

Printer Details on Server-PC (Main)

strange behaviour, I have managed to get it working now with mapped network path for the printer. Last night I have tried various things, this morning I closed sambapos on main PC and client tablet and then restarted again and it worked. I have tested printing from two two clients tablets using HTML, now both are working :grinning::open_mouth: I will continue to carry out further tests.

current settings on client Tablet

## Additional information:
After carrying out further tests below are my findings.

Printer Settings behaviour with HTML

Settings on main master PC (Server)

\NABAB-PC\Star TSP100 Cutter (TSP143)

Setting on Client PC (Tablets)

\NABAB-PC\Star TSP100 Cutter (TSP143)

Actual results

Prints from Client PC’s - No issue
Print fails from Server PC - Error Message displayed

Printer Settings behaviour with HTML - second test

Settings on main master PC (Server)

Star TSP100 Cutter (TSP143)

Setting on Client PC (Tablets)

Star TSP100 Cutter (TSP143)

Actual results
Prints from Server PC- no Issue
Prints fails from client systems - Error Message displayed

Can you please look into this behaviour/bug, I believe following solution would work

The solution to this behaviour is if the printer on Server and Client systems can be set as individually . Currently if you change the printer setting on client system the settings also changed on the server system vise versa.

Settings on main master PC (Server)
TSP100 Cutter (TSP143) (not network mapped)

Setting on Client PC (Tablets)
\NABAB-PC\Star TSP100 Cutter (TSP143) (network mapped)