I can't access to Samba

Hello guys,

today I have modified “data connection string” in “Local Settings” and later I realized the tutorial was for SAMBA3 and not SAMBA4. Now, when I try to acces, appears a warning about error database and the program close itself permanently. How could I modify this field if the program is closing when I try to modify it?

Thanks in advance!


P.D: I have installed the last version 4.1.83

PD2: I’ve tried to uninstall and reinstall Samba, clean the register, etc but the problem persists when I reinstall

It will depend on the database system used as backend to power samba?
Presumably by fact your asking the question you dont remember what it was before?
Do you have and backup zip files as the filename will show the database system used.
Two things to check;
Have you got SQL installed on your machine? If so chances are your using SQL.
Do you have and database files in the samba folder in my documents? if so your using localDB system.

Hi JTR, thanks for your fast reply and kindness. I have installed SQL Express 2012 and Samba is running on Windows 7. In “Local Settings” —> “data conection string” was blank, but I was following a old tutorial and I tried to fill with data source=xxxxxx; User id=xxx; Password=xxx and as from here I can’t open SAMBA.

Uhm, how should be this database file more or less? But it strange because I have tried to uninstall and delete all and when I have reinstalled, it appears the same error :frowning:

What do you get if you set it back to blank?

I believe blank defaults to localDB if connection string is empty…

If you try that and were not using localDB you should get a blank/fresh samba database and will tell you you were using SQL

If you were using SQL
the string will be allong the lines of
data source=localhost\SAMBAPOS; User id=sa; Password=sambapos, database=SAMBAPOS4
However the instance, datatbase user and password will obviously depend on your choices when you stetup first time.

SQL Manager will help you find them more easily…

Reinstall samba will not clear your database and setup as 99% is stored in your database which is seperate to samba software itself.

I installed SQL before SAMBA, but it’s my first time with SQL. I would like to bring all at 0, but I imagine is recorded in SQL, isn’t?

I’m trying to modify data source=localhost\SAMBAPOS; User id=sa; Password=sambapos, database=SAMBAPOS4 but I can’t because I can’t open the soft.

I don’t remembered to set up the SQL, at this moment I think isn’t done this. I just have installed it. I have just opened SQL Manager but is new for me.

Do you know a good tuto for using SQL with Samba?

Thank you

the tutorial for setting up sql 2012/2014 will give you good idea.
When you open managment studio it should give you a login box.
try and login, think if you havent used it before it should be prefilled with the sql instance at lease which will be a good start.

I will try it.Thanks!

Read the tutorial I wrote for SQL Express 2014 it tells step by step. Use 2014 there is no reason to use old software.

Thank you Kendash, I will try with 2014. However, the till is older, just 1Gb RAM. I hope it works on it.

Windows 7 and 1 gig of ram???

Sounds like it would be painful to use LOL

Yes… I’m testing with old machines. Tech recycling, I gues :smiley:

JTRT, absolutely agree with you, Very painful!!!

Hi, JRT, I have the same problem with SQL 2014. I followed Ken’s tuto and I filled up the blank with

data source=Teminal1BAR\SAMBA4…

I have rebooted Samba and now, when I want to acces it warning me about it’s no the rute. I don’t understand, I put SAMBA4 as instance.

Could I let in blank?


Is sql installed on that machine? if so change to localhost\xxxxxx

Yes, SQL Express 2014 running on a 1Gb RAM with W7 and working pretty fine :smiley: (I haven’t got money to invest for new tills).

In the installation I named the instance (following Ken’s tutorial) as X, and I filled the blank through the form in this field called “data connection string” but changing localhost for the name of server I think.

I will test with localhost\XXXX.

Thank you JTRT

The first part is either server name or localhost if SQL is on same machine, second part is the instance.
My server is called JTR-SERVER and my SQL instance is called SAMBAPOS making the first part of my string JTR-SERVER\SAMBAPOS.

user and password will depend on if you enabled windows auth or mixed auth, mixed auth is generally easier to work with if using multiple terminals but wither will work.
If windows auth you shouldnt need user/password, if mixed mode you would have chosen a password, the user ‘sa’ and pasword you set, most tutorials ive read give example of user sa and password of sambapos but obviously if you chosed mixed you would have own password.

Database again is your choice, I use SambaPOS followed by V number ie SambaPOS4 or SambaPOS5 so i could test V5 without messing with V4 install.
If your not sure of your database name SQL Managment studio is best way to check and see what database name is, if you have connected and been guessing you hay have multiple as Samba will make new database is SQL settings are right but database does not exist.

Hello JTRT, yes, SQL is on the same machine. I can connect through “SQL manager” with TERMINAL1BAR\SAMBA4.

I filled the same in SAMBA, so I don’t understand why doesn’t work. And now I can’t acces another time because SAMBA closes warning me is not the correct rute.

I choose Windows Auth on SQL installation.

In summary, I have uninstalled another time SAMBA because I don’t know where I can modify the field. I don’t know where is the file to modify this “data connection string”, and I have tried to erase all about SAMBA, but neither I can’t enter yet because the reinstall doesn’t fix the error.

I think is too hard for me!

No it is not too hard.

Basically you’ll name your SQL Server while installing and tell that name to SambaPOS. While naming you can prefer two methods. If you prefer default instance SQL Server name will be Server Name (*). Second method is adding a named instance. Preferring Named instance will be better for good reasons. If you prefer named instance you need to tell both server name and instance name to SambaPOS. In <server name>\<instance name> format. Like MyServer\MySQLServerInstance.

  • Server name is the network name of the computer you’re installing SQL Server to.

Names like localhost\InstanceName or .\InstanceName will also work if SQL Server and SambaPOS works on same computer.

Also you can prefer Mixed Mode instead of Windows Auth so you can connect to SQL Server with a specific sql user name and password. This is a lot easier than setting up windows users properly. While installing you’ll setup a password for sa user so the user name will be sa and the password will be the password you entered.

Uninstall SQL Server, Reinstall it and keep your attention on how you name your SQL Server.

Thanks for yours explanations, Emre. I’m sure I named “SAMBA4” in Name Instance on SQL installation, so later I filled up as: Myservername(TERMINAL1BAR)\SAMBA4 on Samba Connection String. So: TERMINAL1BAR\SAMBA4 in that “Data Connection String” field (on SAMBA, not SQL).

I’m going to uninstall SQL and SAMBA and I will try again. But the problem is that field “Data connection string” on SAMBA. If you mistake, later you can’t acces more.

I choose Windows Auth, and maybe I put a new user/passwords in that field. This is possible and maybe it is the origin of the error.

I will test it another time more. Thanks.

I thought this is a naming issue because of this comment. You should be able to connect with SQL Manager.

I’ve greatly improved it for next version. I hope it will be easier to configure.