Installation and set up


#1

I wanted to try sambapos pro v5 in the hopes of finding an alternative to our existing restopos system.
However, I am having serious problems with installing v5 pro trial. My feedback after two-day usage is : I am wondering if these bugs are intentionally put in the trial version :slight_smile:
My questions are:
1-Why uninstalling doesn’t delete the database and all settings?
I uninstall and install again and it shows all the settings as if I never uninstalled it.

2-Shouldn’t there be a simple way of resetting the data? (password protected or whatever)
I installed and uninstalled and followed the advice of someone in the forum, and deleted the mdf file in user directory. Even this did not help at all.
And it started to show the LOADING forever.

3-I uninstalled sambapos, restarted the pc now and installed it again, it says :
“Please restart application. Current problem saved to log file.”
(Actually instead of just plain “log file”, it should be something like C:\users…\documents…log . Because I searched it in many different locations) And now still I cannot start sambapos .

4-I am repeating it, I uninstalled it and installed it again. But the new installation fails. This is the first lines of exception :
Top-level Exception
Type: System.Data.SqlClient.SqlException
Message: Cannot open database “SambaPOS5” requested by the login. The login failed.
Login failed for user ‘DESKTOP-76PFB44\Alp’.

5- At some points of my trial of this software I tried to install the integration SambaIn_2.exe . My sambapos installation is in E directory as my windows 7 is in E too. This SambaIn_2.exe, tries to find some configuration in C directory. Probably the default C directory is hard-coded in it.
6-Finally Who is Vehbi? :slight_smile:
Probably when I installed this SambaIn_2.exe . I checked the log file and there was so many lines of C:\user\Vehbi …
In general , this software although seems promising, it needs cleaning and tidying up.

When I visited your forum to write my problems and feedback, I am shocked by the news of the death of the founder. May he RIP and my condolences go to the Sambapos team.
Regards.


#2

Hey Alp welcome to the community. Short answer is no you can not just uninstall the software. The database used is Microsoft SQL express it is separate install than the program. Trust me this is a good thing and protects data integrity. I really advise you to check out KB.sambapos.com and read through the database setup options.


#3

Yes you cannot uninstall DB from SqlServer. If you want to delete it you must install MsSqlManagementStudio and after that you can delete the database.
And may be you can forgot the credentials of SqlServer while you install it. So you got that connection error.
We must check this installation type (directly to other partition)
You found the Vehbi :slight_smile:


#4

Your fingerprints are everywhere, Vehbi, you couldn’t be serial killer definitely.


#5

You found me so you have 3 wishes :slight_smile:


#6

What a hassle for just resetting the data! Install an 800MB giant just to drop a table…
phew!
I must admit that it is very practicle. Anyway you know better.

And Vehbi, Do you have any solution for "hard coded C:\ directory " problem in SambaIn_2.exe. My windows 7 is in E, but SambaIn_2.exe spits out : “in C:\ …” not found error… when i make the same path into the C:\ directory (copy all the path and paste into C:, so that the files are found) it gives another error.


#7

Actually you could use the built in database tools module and go to settings - database tools and select the clear transactions function. That will not reset menu or other config but will reset transactions.


#8

Yes i will look that


#9

I installed MsSqlManagementStudio and i deleted the tables there. Sambapos showed loading and said : “Restart the application. Current problem saved to log file.”
The exception in the log file:
[Exception Info 1]

Top-level Exception
Type: System.Data.SqlClient.SqlException
Message: Cannot open database “SambaPOS5” requested by the login. The login failed.
Login failed for user ‘DESKTOP-76PFB44\Alp’.
Source: .Net SqlClient Data Provider

I restored the original database(with the information in it) to the original location and Sambapos now refuses to start.

Now what?
Very interesting, I have been asking the same question for 3 days and still no solution.

Now, Sambapos doesn’t start with the old stuff in it or without…
I would expect that if there is no database, your app could make a new one… But it prefers nagging instead…

It’s very hard to believe that this software is actually ready to sell.
Regards.


#10

The software isnt the problem. There are thousands of places using it all over the world. The hotel I work part time at has samba for 3 years now with 250k tickets and several million on transactions.
You still have the same login failed error, samba cannot connect to the database with the details you have set.
Deleting whatever tables you had in SQL is t going to change the error message as samba cannot connect to the database.

At this point I would reconmend going in to your program files folder (hidden by default in Windows so you need to show hidden files and folders in view properties of explorer.)
In the samba folder there is a settings.txt file where the non database (local) options are stored - things like terminal name and display settings. Most relivent to you this is where the connection string is stored .
Change the name of this file to something like backup.settings.txt then start samba.
This will make samba create a new one with default local db. At this point you can correctly set your connection string to your SQL express.
I/someone can advise on what the connection string should be if you don’t know, upload a screenshot of your management studio login etc so we can confirm your hostname and instance name.

Did you enable mixed mode auth on SQL install as reconmend do in every tutorial on forum?


#11

Hi,
There is no settings.txt in
1-Program Files (x86)\SambaPOS5 folder
2-Users…\Documents\SambaPOS5
3-Users…\AppData\Local\Samba

Did you enable mixed mode auth on SQL install as reconmend do in every tutorial on forum?
What is this?


#12

I am pretty sure you have been using SQL LocalDB all along and not SQL Express. This is totally fine for a single terminal setup and the default when you install. The SambaPOS installer will download and install MS SQL LocalDB 2014 by default if it doesn’t already exist on the system.

I believe this is your problem all along. I don’t know where on the forum you found that but it is incorrect advice. This is not how you delete a database in SQL Server (LocalDB in this case). If you delete the .mdf file all that will happen is you will get errors because SambaPOS is still looking for the database.

The actual location of the settings file will be

\ProgramData\SAMBAPOS\SambaPOS5\SambaSettings.txt

ProgramData is a hidden folder you you need to set Windows to show hidden files and folders.

Rename the file to something else, like SambaSettings_backup.txt then restart SambaPOS, it should work fine now, it will create a new database either empty or with sample data, depending on whether you installed sample data with the installer at the start.

Forget about this, you are using LocalDB it is not relevant.


#13

Alp this software is in 200 countries and thousands of restaurants. It is the best pos system for customization on the market. Yes it’s a little harder to learn but you can learn it.


#14

I followed your advices as told.
found \ProgramData\SAMBAPOS\SambaPOS5\SambaSettings.txt
saved a backup, and deleted and deleted the database files in user/Alp …
same thing…
Loading Loading… and
said : “Restart the application. Current problem saved to log file.”

Fresh Log File content:
Top-level Exception
Type: System.Data.DataException
Message: An exception occurred while initializing the database. See the InnerException for details.
Source: EntityFramework
Stack Trace: at System.Data.Entity.Internal.InternalContext.PerformInitializationAction(Action action)
at System.Data.Entity.Internal.InternalContext.PerformDatabaseInitialization()
at System.Data.Entity.Internal.LazyInternalContext.b__4(InternalContext c)
at System.Data.Entity.Internal.RetryAction1.PerformAction(TInput input) at System.Data.Entity.Internal.LazyInternalContext.InitializeDatabaseAction(Action1 action)
at System.Data.Entity.Internal.LazyInternalContext.InitializeDatabase()
at System.Data.Entity.Internal.InternalContext.ForceOSpaceLoadingForKnownEntityTypes()
at System.Data.Entity.DbContext.System.Data.Entity.Infrastructure.IObjectContextAdapter.get_ObjectContext()
at Samba.Infrastructure.Data.SqlData.EFWorkspace…ctor(CommonDbContext context)
at Samba.Persistance.Data.WorkspaceFactory.Create()
at Samba.Presentation.Services.Common.DataGeneration.DataCreationService.get_Workspace()
at Samba.Presentation.Services.Common.DataGeneration.DataCreationService.ShouldCreateData()
at Samba.Presentation.Services.Common.DataGeneration.DataCreationService.CreateData()
at Samba.Presentation.Bootstrapper.InitializeShell()

Inner Exception 1
Type: System.Data.Entity.Core.EntityException
Message: The underlying provider failed on Open.
Source: EntityFramework
Stack Trace: at System.Data.Entity.Core.EntityClient.EntityConnection.Open()
at System.Data.Entity.Core.Objects.ObjectContext.EnsureConnection(Boolean shouldMonitorTransactions)
at System.Data.Entity.Core.Objects.ObjectContext.ExecuteInTransaction[T](Func1 func, IDbExecutionStrategy executionStrategy, Boolean startLocalTransaction, Boolean releaseConnectionOnSuccess) at System.Data.Entity.Core.Objects.ObjectContext.<>c__DisplayClass651.b__63()
at System.Data.Entity.Infrastructure.DefaultExecutionStrategy.Execute[TResult](Func1 operation) at System.Data.Entity.Core.Objects.ObjectContext.ExecuteStoreQueryReliably[TElement](String commandText, String entitySetName, ExecutionOptions executionOptions, Object[] parameters) at System.Data.Entity.Core.Objects.ObjectContext.ExecuteStoreQuery[TElement](String commandText, Object[] parameters) at Samba.Persistance.Data.Initializer.InitializeDatabase(DataContext context) at System.Data.Entity.Internal.InternalContext.<>c__DisplayClassf1.b__e()
at System.Data.Entity.Internal.InternalContext.PerformInitializationAction(Action action)

Inner Exception 2
Type: System.Data.SqlClient.SqlException
Message: Cannot open database “SambaPOS5” requested by the login. The login failed.
Login failed for user ‘DESKTOP-76PFB44\Alp’.
Source: .Net SqlClient Data Provider
Stack Trace: at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, UInt32 waitForMultipleObjectsTimeout, Boolean allowCreate, Boolean onlyOneCheckConnection, DbConnectionOptions userOptions, DbConnectionInternal& connection)
at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, TaskCompletionSource1 retry, DbConnectionOptions userOptions, DbConnectionInternal& connection) at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection)
at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource1 retry, DbConnectionOptions userOptions) at System.Data.ProviderBase.DbConnectionClosed.TryOpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource1 retry, DbConnectionOptions userOptions)
at System.Data.SqlClient.SqlConnection.TryOpenInner(TaskCompletionSource1 retry) at System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource1 retry)
at System.Data.SqlClient.SqlConnection.Open()
at System.Data.Entity.Infrastructure.Interception.DbConnectionDispatcher.b__36(DbConnection t, DbConnectionInterceptionContext c)
at System.Data.Entity.Infrastructure.Interception.InternalDispatcher1.Dispatch[TTarget,TInterceptionContext](TTarget target, Action2 operation, TInterceptionContext interceptionContext, Action3 executing, Action3 executed)
at System.Data.Entity.Infrastructure.Interception.DbConnectionDispatcher.Open(DbConnection connection, DbInterceptionContext interceptionContext)
at System.Data.Entity.Core.EntityClient.EntityConnection.b__2()
at System.Data.Entity.Infrastructure.DefaultExecutionStrategy.Execute(Action operation)
at System.Data.Entity.Core.EntityClient.EntityConnection.Open()


#15

Jesse,
I came here and gave a try to SambaPos, because I wanted to experience the same good stuff myself.
What I wanted to do was extremely simple thing. I just wanted to clear all data in SambaPos. If I tried to do something difficult, yes your remark “Yes it’s a little harder to learn but you can learn it.” could be justified. But just clearing all data should be simple.
We are using already a pos system (RestoPos). And I noticed the software developers of Restopos do not want a simple installation of the software to strengthen the resellers of the software. (If the end users need support resellers provide it and get money from the user, and if the resellers earn money, they sell more. If the resellers are strong then, the software developing company gets stronger. A satanic system in short words)
So this can be the same case here :slight_smile:


#16

Clearing data Is simple. There is a task for that in database tools in settings. You can also just define a new database name and connect to it if you want a fresh config. Or you can just log into mssms and delete the database and just load sambapos again it will create a new one.


#17

The reason sambapos is a bigger learning curve is because they allow customization of almost everything something no other pos allows. Because of that it requires more technical knowledge


#18

“Clearing data Is simple. There is a task for that in database tools in settings. You can also just define a new database name and connect to it if you want a fresh config. Or you can just log into mssms and delete the database and just load sambapos again it will create a new one.”

I logged into mssms and deleted the database and loaded Sambapos and it doesn’t even start.


#19

But you had that problem before you downloads sqlmanager and deleted!


#20

How did you delete it? You are probably on localdb in that case it’s not as simple. I always recommend installing full sql it will mean if you need multi terminal you will be ready for it. Localdb only supports one terminal.