Invalid #colour in menu item settings causes crash on login


#1

Just to report minor bug/issue.
If you set an invalid #code for submenu button colour you get crash on login.
In this senario the use mistakenly replaces a #code colour with #red leaving the # in there.
Removing the # leaving just red solved the crash but needed to do via SQL manager.
These fields should have a cleanser/checker on them to ensure no issue like this.


[5.2.3] Issue Compilation
SambaPOS 5.2.7 Release
#2

By 5.2.7 it should display a validation error on menu screen when incorrect color codes used for sub menu color configuration.


#3

@emre 5.2.7 got released 7 days ago… :wink:


#4

Oh yes I know sorry for the confusion. I just wanted to mention how it resolved.


#5

This is correct, I just tested this on a new installation and it works!


#6

Just gone to update the menu with a new product and I get this error before I can even do anything.

The settings have been like this for over a year, but only recently updated to the newest version.

Please advise which color code do I use?

Thanks


#7

Go into edit product properties and what colours you have assigned to each product I think that is where the issue is

This did only happen on a recent update where invalid codes/formats are not allowed


#8

Have you upgraded to the latest version as I thought this was fixed?


#9

You should be on 5.2.14


#10

I have updated to 5.2.14 after doing so tried to add a product, but get this message, which in turn does not allow the save button to work.


#11


#12

What you selling? Top secret stuff :-p
Message says sub button (submenu) scroll to the right and check those colours too.


#13

Nothing top secret, just protecting the privacy to be honest. Wish it was top secret stuff would have a bigger margin than lol.

When I scroll to the right it does not have colour options, other than what I have shown.

It was working before the update, but now its picking up a error, but whats triggering it.


#14

Food doesn’t have privacy lolol ok just kidding.


#15

That relates with Sub Button Colors of All category. Do you have empty space string there?


#16

Yep thats the magic I was looking for, in one of the buttons it was selected with Red, so I deleted that and the notice has gone.


#17

Yeah I know but if I post the items, you will be able to “google” the location lol.


#18

lol I know we should improve these validation error messages but wasn’t it clear enough?


#19

I was looking in here and saw the sub color box was empty, sorry I did not try the all category box. That`s where I was looking into with the error.


#20

That’s OK. Just wanted to be ensure if error message is helpful or not. Seems like “All Category” not understood like “The Category named All”. I’ll improve that.