Inventory Purchase alternative quantity

Hello @emre and readers.

Can somebody please explain why this does not work? I have defined alternative Unit but receiving the quantity fails…

Inventory Item

Purchase Transaction


This works fine if I use the BASE Unit:



  1. I wish to list “Bottles” on my stock reports for Wine.
  2. I wish to list Stubbies on my stock reports for Beer.

Ok Emre I going to place this GIF here as well so I hope you do not miss it being buried down the line?

Is this below by design or an Issue as I cannot seem to save additional Unit (NOT to be used as Transaction Unit for Reporting):

The only way I can save “CARTON” as an Unit is to Save, then Edit it back down to Additional Units?

If you change anything with units above then you must save and go back in to set additional units.

That is by design to prevent duplicate unit name. Perhaps its not a graceful solution but it works.

1 Like

Ok thanks @Jesse.

I still have an issue with the setting up of a WINE CASE as in the image below you can see (and may have overlooked) the error in calculations:

It does not look right to me?

The Inventory Item setup is above - so how do you specific a CASE (12 x 750ml Bottles)? Do you need to enter CASE in mL which is 750 x 12 = 9000mL.

Didnt Q make a tutorial covering just about all inventory setup possibilities? Im gonna look i swear he made a nice diagram even.

Edit: here it is.

1 Like

I was scurrying fast to try and find it as I dare not call him :worried:

Its long i recomment taking it in pieces and practicing in portions of it to get familiar then try your setup that you want.

Yes I think the problem is I have used a BASE Unit in mL and then tried to show a CASE as BOTTLES given that I defined BOTTLES above.

It seems CASE needs to also be in mL?

I don’t think so, no. Please hold, let me check something.

EDIT: this all looks correct.

I specifically chose to test 2 different product setups.

Remember these things when you set up Inventory:

  • Inventory Reporting is by Transaction Unit, or in its absence, by Base Unit
  • Purchases can be by any unit defined: Base, Transaction, or Additional
  • Recipes can only use the Base Unit.

1 Like

Sorry for the delay @QMcKay but needed a few hours sleep before up early to take my son Rugby training.

Now can you please show me how it is reported? I have a small difference as I want to report in Bottles i.e. 8.2 Bottles not mL?

Can I elect in the Inventory Tags REPORT to display by other Units…

This is the result using your method Q - unfortunately using the smallest method “mL” makes it interesting.

So 11.8 BOTTLES makes more sense than 8,850 mL.

Ok I think my original setup should of worked as it now is working fine using a BASE unit in mL and a transaction unit in BOTTLES! It seems “remnants” of previous attempts were still lurking in the background? Any new fresh Items work fine so all I can say is you need to be careful on the initial setups.

** COMMENT - When I say remnants I refer to the fact that even though I had nothing in the Transaction Unit Line - I could not get rid of the 750 “Multiplier” no matter how many times I saved and existed as an example.

Yes, when you change the Item setup it will do “odd” things, so you want to be sure you do it right the first time. Still, after such a change, you can make corrections to physical inventory using the End of Day record once the Workperiod is closed.

It won’t let you blank it out once it has be en set. To get rid of it, set the Transaction unit to blank, and set the Multiplier to 0 (blank will not work here), then Save.

1 Like

Hi, was this fixed in the new releases ie we are in 2017 and I had this problem the whole day

This was never a bug or issue it’s designed that way and it’s unlikely to be fixed due to how reporting works. You can define a new item and spell it the same maybe add one character to it. Use that new item from this point forward.

However it’s important you explain your problem so we are sure it’s the same.

The behavior is to avoid creating Additional Units that have the same Name as the Transaction Unit.

You cannot remove the Tx Unit and create an Additional Unit having the same Name in 1 step. Instead, you need to do it in 2 steps:

Delete the Transaction Unit:

  • Put 0 in the Multiplier. (blank/empty does not work for the Multiplier)
  • Clear the Transaction Unit (blank/empty)
  • Save the Item.

Create the Additional Unit:

  • Open the Item. (Tx Unit Name should be gone/blank/empty, and the Multiplier will remain at 0).
  • Add an addition Unit and set the Unit, Multiplier and Parent Unit.
  • Save the Item.

Thanks for the reply, but I cant understand the reason why even after deleting the inventory item there are still traces of the deleted inventory item, whats the reasoning behind this

Secondly, is there away i can capture purchases without using portions, I only want to know at the end of the month how much I have paid to each supplier, i am not really interested in the consumption rate and related cost as i will do that later

If yes how can I set it up, thanks

Probably because the Item is in the Purchase records and/or the Consumption records.

Inventory Item Purchases have no related Portion. That is, an Inventory Item does not have a Portion Property. A Portion is a Product Property, and us normally used in Inventory Recipes.

So your Inventory Purchases (quantity of an Inventory Item, and the Cost to Purchase) is generally constant for the Unit of the Item that you Purchase. The Product Cost is different. It is calculated from the Recipe, the quantity of Inventory Items the Recipe consumes, times the Price of the Inventory Item Base Unit used in the Recipe.

The direct answer to your question is “YES”. Inventory Purchases are what you have “paid to each supplier”, and in that case, the “Cost” is what you have Paid Out.

Define Inventory Items. Purchase Inventory Items using an Inventory Purchase Transaction. That’s it.

This Report will show your Purchases. Modify it as necessary for your needs:

[Purchases by Group:2, 1,1, 1]


[Item Purchases:2, 1,1, 1]


thanks so much. ill give it a try

Hi, can somebody help, I cannot edit my inventory items, even when I delete the item and reenter the original cost come back, for Instance

I have bar soap that I normally buy from supermarket, I had set it as follows:

Base unit : bar
Default cost :0.00

Transaction Unit: Box,
Default cost is: 180

I also tried using Additional unit as below

Base unit : bar
Default cost :0.00

Unit Name: Box,
Cost is: 180

Which is the best way to set inventory items? Should I use I use transaction unit or additional unit, Having in mind that am setting this only for purchase and not for portions or recipe

There is a really good inventory tutorial in the v5 tutorial section. You should read that because it sounds like your just beginning with inventory.