Licence constantly deactivates

Hi there

I am now working with Sambapos since june V5.1.62), licence activated.
windows 7 - Samba server,
5 windows users:
1 user uses the windows 7 comnputer itself (SambaPOS server)
4 users access that computer through remote desktop (RDP)

I am in the middle of the Jungle so the internet is not perfect, sometimes no internet for a couple of hours.
So it’s kind of hard to work withSambaPOS … I have to re-log to the 5 terminals and that’s really annoying, really.

However now I am facing another problem, no matter if I login, close samba, reopen samba, it says that I have to activate some module but the activate button of the licence module is disabled (grey) and it shows “working in trial mode”.

I am backuping (with actions) but I haven’t reloaded a backup since the start (in June).
Never used “training mode”
emreAug '16I'm asking just to be ensure. You're logging in to windows always with same windows user account name, right?
Logging to windows with 3 or 4 concurrent users

SambaPOS works great but this licence module is making my daily work really hard.
We are open from 6 am till 2am, so 20 hours a day, 7 days a week and the internet can fail anytime, so I have to come to the restaurant at really anytime to fix it. Waitresses cannot (espcecially the “activation warning”)

1 Like

Issue with license key has been solved many times here, just login to sambamarket and clear license, then re activate.

Check here for details or search forum: License problem

1 Like

I Windows 7 would not support multiple RDP sessions without a patch/crack making your setup one which would not be officially tested.


I logged in
Clear the keys

In SambaPOS, I Went to Sambamarket, logged in, activate became “enabled”, I cliked “activate”, problem solved.

(that’s true that there are a lot of posts about licences problems which makes it difficult to find the most efficient solution.)

Solved just for 2 days …

once again same problem:

You have modules that need to be activated.
Please activate them.

(Activate Button grey out)

Backuping my database with a trigger everyday at 5 am.
Action Type : Backup Database; running in background : true.

Does that yellow setting have an effect on my problem?

I’ll try:

“disable manage licences” although I am .62


So I unclicked yesterday “Manage addon Licences on backup and restore”.

(I am daily backuping with trigger, I never had to reinstall a backup, just backuping no restore)

24 hours later, SambaPOS still working without that annoying “please activate your modules” message.
So far so good.

25/10 so far so good

26/10 :confused: once again … broken.

1 Like

Hi, i use Sambapos since 2017 and had this problem sometimes but fix it with recommendations of this forum.

Today i’m very tired.
I change my software from windows 7 to windows 10 and instaled the last version of SambaPOs a week ago.

Since that day its a nightmare with each day a Licence issue.
I tried all i found in this forum.

the post of JR helped me before but in this case nothing

JTRTechOfficial SambaPOS Reseller

Dec '18

Do you use training mode? There were issues with the database duplication that this entails causing licence issues before.
Its an oddity, I manage 5 systems daily locally for clients who have not needed reactivation since install, one it about 3 years live now.
Id suggest a clean sweep for licence/module;
Uninstall licence module on all terminals.
Close all samba instances.
Clear database key on samba portal.
start samba on main machine
instal module
restart samba
start and install module on all other terminals then restart.

Some one to help please.

I had licence deactive problem every day 1 year ago, what was causing the issue was that who was closing work period wasn’t waiting to finish the backup process. I turn off auto backup at the end of the day and the problem in my case dissappeared, it fixes if the auto backup finish and then power off pc.

Pay attention if someone is not waiting to finish the backup. That was my particular case.

1 Like

I tried that yesterday, we will see.

So you don’t have any automatic backup since ?
Someone from Support to help ?

Thanks Francisco

This is not a support forum. You can email support at

Thanks Jesse, i am in contact with someone.

When i say support, i talk about people who is very good with Samba POs.

Sorry, but my english is not waouuu.


So its seem that to turn off the backup automatic at the end of the day solved the problem.
Its weird because before i did not have any problem.
Anyway problem solved.

Now need to looking for an other automatic backup way …


Did you have the license management option unchecked in backup options? It should have been checked.

Thanks Jesse, seem its working well