Message server not connected

Hi,
I just installed SQL Server express, When i run sambapos4, message in the bottom
Server not connected.
Please help.

and please help me to convert my old database from my documents sambapos4.sdf
I have finished all these steps(How to migrate from SQL Compact Edition (sdf file) to SQL Server 2012 Express) but still my data is not there.

Thanks,
Sid.

can you make sure the port settings and SAMPOS messaging server is configured and running.

Message Server Not Connected is not an SQL Express problem. Message Server is a program that SambaPOS uses to synchronize multiple terminals with real time updates.
Look here for Message Server setup - Auto Refresh Widgets/Button Colors

As far as converting CE to SQL, you will to change your Data Connection String in Manage->Settings->Local Settings to

data source=localhost\SAMBAPOS3; User Id=sa; Password=sambapos; Database=SAMBADATA2;

Then save, exit and restart SambaPOS.
Assuming you have followed the link you mentioned EXACTLY.

Thanks guys much appreciated for your response its working fine, i wasnt started the messaging server that was the problem.

Sid.

i receive this error message on clicking the meassaging server

i even try to change the port 8080 to 8383 still receive this meassge?
what to do

cant open the image?

This is a quote form original post. You can click the arrow to display full post.

thnks both of u i can se 2 server running in the tray but dnt knw hoe to stop thm?

You can stop Samba Message Server using following methods:

Stop Samba Message Server by Windows Task manager

Under Windows Task manager select the samba Message Server and select end task one by one.

The Other method I use is:

Using the Mouse Move the Samba Message Server (B) error box to unhide the Samba Message Server Port settings box.

Click Continue © and then Untick Start Server Automatically.

You can also refer to below guide.

i tried both method thn restart sambapos still both server run

and if try to end task by clicking on one thn both server will end

anyways when i run samba on the login screen i get the message connected.

for info… if the Samba Messaging server is running then you should see following under Task manager. In the example below, I’m running both messaging server. only one messaging server is required

thn how do i fix it i have followed the steps on the tutorial above…even try reinstalling the samba still get the same problem

i am getting this

so is it same

@madiha, from your screen capture I can only see one messaging server running. so that’s fine. please refer to step by step guide on Message Server Tutorial and check all your settings.

thnks @morshed1 for your support