Message server not working as a service


#1

Hi, whenever I change the port and add + and click update port it cannot save because when I check it its without +, am using port 8383 so for the Service Tool I use 8383+


Message server error on V5
Message server error on V5
#2

Show us some screenshots.


#3

Ok, I will when I get to the machine, but its in V4 not V5


#4

So if its version 4 then NONE of this applies. This is only v5. Version 4 does not have the added features that v5 does and thus you would not define a + at end of port for version 4. Additionally the only reason we use the + is if we intend to use GraphQL which is not supported in v4.


#5

Ok thanks, but whats the solution for v4, the message server worked but it need to be started every time the machine is restarted


#6

You can use the tool to install it as a service on your server machine.


#7

I tried as a service using the tool but did not work, when I add + to the service tool then it start. I use port 8383+ so when I use the tool without + it does not even start, When I add + it start but the terminal cannot connect, on terminal I use 8383 and not 8383+


#8

So with version 4 putting a + at end does absolutely nothing that was introduced with version 5 so please lets forget that. Here are some steps to do. Version 5 includes a lightweight HTML server embedded in the message server service and it is enabled with the + it has absolutely nothing to do with the service from v4.

What version of windows are you using?

Please provide screenshots of the tool you are using as well so we can be sure your doing it right.
Provide screenshot of the service.
Explain the steps you took to connect SambaPOS to the message server. How many tills are you using. What till is running the service?
Make sure the windows firewall is configured to allow that port or just turn firewall off.

  1. make sure the port you want to use is not already being used.
  2. once you start service go to services to check for the service running.

If service is not running then try a different port. Once you get service running then try connecting SambaPOS to it.


#9

thanks, am running windows 7, ye I will provide screen shot by tomorrow


#10

You have more than one till right?

This might help you btw.