Message Server Tutorial

What is Message Server?

Some users thinks they need to run Message Server to be able to connect to SQL Server. Message Server has no relation with database and if you have problems configuring database please read SambaPOS Database Configuration topic. After configuring database connection come back to this tutorial to complete your network connection.

Message server is a special server application that enables communication between terminals. On a network environment waiters uses different terminals to enter orders. However other terminals waiting on Table Screen does not update table color changes automatically. When a terminal connected to message server it can understand when it needs to refresh screens so when you create a ticket from a terminal all other terminal screens will update automatically.

Message Server Not Connected error message does not mean Database Not Connected. It means your terminals does not refresh automatically when tickets created.

On this video you can see how an order received from Ipad changes table colors on other computers.

How to configure it?

You need to run message server application only on SERVER computer. In the other words run it on the computer SQL Server runs.

You can run Message Server as a windows service or standalone application. Configuring Standalone App is easier however you need to keep it running. Once you install it as a windows service it will always run in the background and there will be no risk to close it.

###Running Standalone App

Navigate to SambaPOS Installation Folder with Windows explorer and start Samba.MessagingServer.exe program.

When you start running it you’ll see Server configuration window. Click Start button to start running server.

Server will be running on 8080 port. On first start Windows Firewall will ask if you want to allow Message Server.

You can enable Start Server Automatically setting to make it run automatically when windows restarts.

Click Allow Access button. If you don’t allow access SambaPOS won’t be able to access Message Server.

When message server started it hides itself to System Tray area.

If you don’t see it in tray please expand tray and look for the apple icon.

You can click on Apple icon to display message server window. Please just minimize it to hide it to tray. Closing this window will close message server.

Running message server multiple times may generate errors. When you receive error while starting message server please be sure it is not already running as a standalone app or windows service.

If message server running properly you’ll see Working... label under window. You can click Stop button to stop message server.

###Running Windows Service

You can prefer installing Message Server as a windows service. Please run it only on server computer and be sure standalone app not already running.

To run service installer app open SambaPOS installation folder with file explorer and start Samba.MessagingServerServiceTool.exe

You need to have Administrator privileges to be able to install services.

Default Port for windows service is 8383. We’ll need port number while configuring terminals so note the port number somewhere.

Click Install Service button to start.

It will install windows service and start running Message Server. To check if it is running fine or not you can check Task Manager’s Services tab. It should be Running.

You can close Service Tool window. Messaging server will always run even you restart windows and you don’t need to care about it anymore…

###Configuring SambaPOS

On client computers you need to configure SambaPOS to connect to message server. You need to do it on each client computer.

Run SambaPOS and open Management > Local Settings

  • Message Server Name: Type here the name of the Server computer. For example if your server name is SERVER-PC type SERVER-PC here.
  • Message Server Port: Type port number here. If you’re using standalone app default port number is 8080. For windows service it is 8383.
  • Auto Start Message Client: Enable this setting to reconnect to Message Server when you restart SambaPOS.

Click Save and Restart SambaPOS

Windows will again ask if you want to allow SambaPOS to access to Server.

Allow it by clicking Allow Access button. If you don’t allow SambaPOS won’t connect to message server.

When SambaPOS connected to a message server you’ll see Green Connected label here.


Are there additional required steps that might be missing?
I followed the instructions above and got the “Connected” status on both my server and client, but auto-refresh is not yet working (manual refresh, such as re-clicking the entity screen, works).

On the server: I add an order to a ticket. The entity color goes from the default gray to a red.
On the client: The entity color remains gray until I click something to trigger refresh. Then the entity turns red.

I have tried various combinations:

  1. Client order entered. Server does not auto-update.
  2. Server order entered. Client does not auto-update.
  3. Tried using same accounts (both admin) on both client and server. Tried using different accounts (one admin, one user) on each machine.
  4. Tried messaging service standalone and messaging service windows service
  5. Firewall disabled on both machines

My config:

  1. Server: Windows 7 VM. Wired to a router.
  2. Client: Windows 8 physical host. Wired to same router.

Any ideas what I can try?
Thank you,

Be sure you’re running message server only on server and all clients connects to that server. Check Management > Local Settings on all clients. Message Server Name should be the Server's Name

I am also experiencing problems with messaging server since the update to 4.1.40
Terminal is not updated with the changes from the server, after restarting SambaPos it works fine but after a few minutes the same problem occurs.

@pizzaeilat4 nothing changed on that part for years so I don’t know if a recent change is the reason of it. Let’s wait for other user’s responses if anyone recently started experiencing such issue.

I installed the 1.4.39 version back and it works fine only version 1.4.40 has a problem

@pizzaeilat4 this is probably something different. I’ve checked differences line by line and I found nothing between 39 and 40 that can cause such issue. I believe it will reveal soon if it relates with a bug.

You are right it is not related to the version I’ve restore my operating system
And I reinstalled 4.1.40 version and everything works fine. It likely was related to my operating system settings.
Sorry about that :blush:

1 Like