Odd issue with Samba 5.2.20 not opening

Odd one, today have tried to open samba and nothing, no loading, no errors.
Windows logs show a couple of issues;

image

Tried reinstalling samba itself, no change.

Restartred SQL service etc - no change.

Am in SQL with mssqlm and all seems ok, db show and open.

Looks like something .net related - at least on one, should i try reinstalling .net?
Luckily this is just my dev machine.

Found I had an installed awaiting restart update in que so just running that now to see if thats maybe the cause.

I had the exact same issue when I first installed it, I downloaded and ran the installer again and it worked so didn’t think anything of it

Update didnt help, tried again to uninstal, fresh download of 5.2.20 and reinstall, similar issue, doesnt start and following event logs;

I had a windows update that caused that one time. I had to rollback windows versions.

That is odd.

I had no problem installing this version on 3 different terminals.

It works fine for me to but like I said I saw it once when a windows update hit. I rolled back windows and it worked… next day I tried the update for windows and it worked just fine…

Still wondering why I keep banging on about Linux? :stuck_out_tongue_winking_eye:

Oh wait, sorry Jesse, it was @JTRTech who was asking why I keep looking in to it… But this reason was on my long list! :slight_smile:

why it says framework version v.4.0 i dont understand that.

Linux is not without its issues. 99% of the time Windows is very stable. Most people that have issues are running home versions or have other apps that really cause most of the issues or they do not lock down updates etc. My particular case I was running insider build.

1 Like

I have noticed a few times 5.2.20 won’t run immediately when you download it.

I noticed on my PC when I downloaded with Chrome, Chrome hasn’t “finished working” with the file, I noticed this when I tried to move it out of my downloads folder it was still in use by Chrome.

Yesterday I installed for someone with Edge browser, it took over 1 minute to complete the “security scan” then came up with an error saying the publisher is not identified. This is my first time to ever see this error message (it also highlighted in red). It could however be a new feature in Edge, I never use that browser…

My assumption is on both browsers it’s being cased by security scans after download. I haven’t noticed this on previous versions and also I don’t get this issue when installing on a POS terminal running Windows 10 Enterprise.

@VehbiEmiroglu I don’t think the SambaPOS installer was ever digitally signed anyway but I don’t see why this latest version seems to be acting differently, has anything changed in how you built it compared to earlier versions?

1 Like

Yes we never digitally signed. And we dont change anything in last version. May be Microsoft changes something :slight_smile:

1 Like

I think we must digitally signed our setups and application for this.

4 Likes

It’s a good thing to do because it will eliminate any of the issues you get with warnings of “unknown publisher”. Also anyone then wanting to install on Windows Server don’t need to alter their security settings to run / install it.

1 Like

@Jesse am strugling with a clear way to rollback on updates in win 10, found earlier version but doesnt offer choice like revovery used to on 7 ie back to say 20/03/19 when x updates installed.
Found option to uninstall updates however there are many and they wont organise by date.

If you use earlier version that will rollback 1 version.

I used the insider releases so of your not on insider I wouldn’t rollback it may be something else.

Ok, will try, it wasnt very clear on what it defined as ‘version’.

Rolled back, same issue :frowning:

Hmm try a new install of .net?