Playing Kitchen notification sounds for new orders

I don’t see the rule that executes the broadcast.

And media player is installed and set up on each machine? Also try using a show message action to test the message received.

Ok, I did the show message action. Nothing came up when i triggered it. I verified that media player is installed and setup and that the sound is accessible from the kitchen terminal.

Could this be an issue with the message server?

Could be, if you are not seeing the Show Message. But if your KD is updating properly, that indicates Messaging is working.

You can try this to test Messaging:

Also if the other terminals have a ticket open the time message is to be received it will not execute the rule and that is how it is designed to prevent people from damaging the system.

The funny part is, it is not working the way it is designed. I had to set a refresh timer to refresh the screen every 3 seconds. Also if the table screen is open on one terminal, it does not update it when a change is made unless you exit and reenter. I have no idea why tho.

Typically when that happens usually it’s due to custom automation interfering or rule debugger is on.

By design it refreshes screens every submitted ticket.

Then Message Server configuration is incorrect and it is not working properly. There should be no reason to set a timer. Just check the box for Auto Refresh and set the Interval to 0.

Run the Message Server Service Tool (Samba.MessagingServerServiceTool.exe) on the Server machine only, which allows you to set the port and install the Messaging Server as a Windows Service. Once this is done, there is no need to run the Tool again, unless you need to change the port for some reason.


If you set the port in the Tool to 9000+, then your Terminals (all of them, including the Server) should have the Message Server Name set to http://MYSERVER (or an IP address like and the Message Server Port set to 9000, and have the box checked for Auto Start Message Client.

When you look in the Windows Service Manager, you should see the Messaging Server Service running, on the Server machine only, and NOT at all on any other Terminal …

You might need to open the port in the Windows Firewall (or any other Firewall program you might use) for the Messaging Service on the Server machine only. Other Terminals do not require an open port …

Yes, I have done all of the above steps. I’ve set my port to 9000+ on the server and verified that it is running on the server only. I used my server ip address to connect each client to and set their port to 9000. They all say connected in the lower left corner and when I run the connection test it says successfully connected. I have actually turned off firewall completely on all machines and to no avail.

Have you simplified? Try just a very basic broadcast message and message received rule with a popup action, no constraints other than the actual message name bit.

Yes, I have tried that. Message was set to say hello. Did not show up on any terminal.

Care to share screenshots.
I notice your hard coding your actions, I reconmend ‘carrying’ the field with [:Field Name] so it can be set in the rule.
Changes made to action after adding to rule are not updated unless action is removed, rule saves and the readded.

I created an automation command with a button that says hello. Set it to trigger the broadcast message and send the command Hello. Set a rule up to receive the command and show a message box that says Hello. Also the screen shots shot my server setup with message server running and the settings and a screen shot of one of the client terminals. This is sure a lot of work for a simple sound to play. lol. I ordered a printer that is esc/pos compatible that will ring a bell. Maybe ill just set it up as the bell to ring when an order is received but not print. Seems easier.

Thats not right though…
You put the broadcast message action in an automation command executed rule to make the button trigger the broadcast.
Then you have a message received action which triggers your popup.
From your screenshot there is NOTHING happening on your button press on the hello automation command.

JTRTech is correct. Your Automation Command is never executing because you have no Rule to handle the command.

Also, your Message Server Name has the incorrect slashes ( \\ ). It should be forward-slashes, like:

Install the MSTC DB Tools import File. It is the easiest way to check your Messaging Service…

I just now saw this reply.

Thank you for that correction, I fixed it and I installed MSTC DB tool and tested it. Nothing happened on the terminals.

Then your Messaging Server service is not configured properly. Please continue this discussion in the other Topic (see my latest reply there).