Playing Kitchen notification sounds for new orders


Hello everyone. I have my system setup with kitchen display and wanted to play a sound when an order is received. I setup my action and the sound plays fine on the server. I am a little confused on how to setup the broadcast message. I tried reading the topic but still can’t figure it out. Here is my setup.


You need the same sound in the same location on each computer. Or put it on a networked drive or share.


Right, i did that. It is in the public music file and is shared across the network with read/write permissions. The sound plays fine on the server machine but not on the kitchen display. I only need it to play on the kitchen display and no other machines.


Your screenshot shows a local file on the C drive, not on a Network Share.


Sorry, what I meant was i did that after you suggested it, I forgot to upload new screen shot.


I just am not sure what command I would use in the broadcast message action box to get it to play on the kitchen display system.


Then you will need to remove the Action from the Rule, save it, re-add the Action and save it again.

This is why it is not recommended to hard-code the parameters in Actions; instead, use a [:variable] for the Action, and set the parameter via the Rule.

Also, Starting a Process that is an MP3 file may or may not work since it is not executable. What Program plays the MP3 file?

P.S. the Use Shell Execute parameter when set to True is supposed to automatically use the default Program for opening the file type.


Ok i did that.Still only plays on the machine that enters the order but not on the kitchen display.


I use windows media player. it is set as my default.


It is arbitrary. The command could be “FLUFFY”. Then you have a Rule for Message Received with Rule Constraint of Command Equals FLUFFY. Place your Action in that Rule.


ok, so i could have it set to broadcast Play Sound as command then set up message received to look for that command? Ill give it a try.


Exactly. Just make sure the Command that you Broadcast exactly matches the Command constraint in the Message Received Rule.


Alright, I still must be missing something. I did that and still only plays on the server (terminal where i entered the order) which we don’t want. Here is my setup. I also verified that it is connected to message server and setup correctly.


I also tried entering a new order directly on the kitchen display system. The sound plays fine on there but only if the order is entered on that system. So it seems that the sound will play on any terminal where a order is entered but it will not play on the kitchen display if the order was not entered there.


I don’t see the rule that executes the broadcast.



And media player is installed and set up on each machine? Also try using a show message action to test the message received.


Ok, I did the show message action. Nothing came up when i triggered it. I verified that media player is installed and setup and that the sound is accessible from the kitchen terminal.


Could this be an issue with the message server?


Could be, if you are not seeing the Show Message. But if your KD is updating properly, that indicates Messaging is working.

You can try this to test Messaging: