Problem with touch on right edge of screen


#1

On v5.2.3 I am experiencing no touch input in SambaPOS only on the right side of the screen.

EDIT: I don’t believe it’s related to v5.2.3 - I have a customer on v5.2.2 with the same issue.

I believe it is the same issue as reported here 30 days ago, but since the YouTube video is no longer available on that post, I can’t be certain, also there was no further posts after recalibration was mentioned, so it may not be related since I’m using a capacitive multi touch screen on a tablet which doesn’t require calibration. So I’ve started this new post.

A column down the right side of the screen doesn’t work with touch. It works fine with the mouse. I have experienced this now with 3 separate tablets with different spec. All are running Windows 10 Home with latest build 1803.

On the above video, I am also using the -notablet parameter on starting SambaPOS. Without using the parameter, the non responsive area on the right is larger.

I can’t be certain, but I have setup tablets in the past and did not notice this, so wondering if it is related to a windows update or change in touch input in the latest build of Windows 10?

In Windows and other software, the touch works perfectly to the edge of the screen. However I did notice this very strange behaviour which you can see in the video below. If SambaPOS is open, in a window and I open Microsoft Edge, it would appear the UI controls also don’t work on the right edge, or even at all. Once I close SambaPOS, Edge works perfectly including right up to the right edge of the screen!

So everything I am setting up on is using multi touch capacitive screens (so not a calibration issue - you only need to calibrate resistive touchscreens). As I am also using 15" touchscreen POS terminals with multi touch capacitive screens and they don’t have any problem, I started thinking about what is different about a tablet.

I checked that all the tablets are using display scaling of 125% or 150%. I thought this might be the issue, but I tested without display scaling (i.e. set to 100%) and the problem still exists.

Everything I have tested with and without the -notablet startup parameter.

On the specific tablet in the video, it’s a Linx 12X64 with 12.5" screen, 1920x1080 resolution.

Other systems I confirm the same issue with are a Linx 1020 with 10.1" screen, 1280x800 resolution, and a PiPO X9 “mini touchscreen system” (basically a tablet without a battery) with 8.9" screen, 1920x1200 resolution.

I do wonder if it is related to the Windows 10 build, which is quite serious then as if this is the case, many people are going to start to experience this issue when their system updates. Going back to thinking what is different with a tablet and a POS terminal that have the same screen type, I can only really see it as the Windows 10 build. The tablets I use are consumer models so running Windows 10 Home, currently at build 1803. The 15" POS terminals, which have a 1024x768 PCAP (capacitive) screen and do not experience this issue, are running Windows 10 IoT Enterprise LTSB Entry with build 1607 (being LTSB “long term support for business” version they don’t get feature updates so will remain on 1607 build forever).

Any suggestions of anything else I can try?

@emre


#2

hey Mark I am fairly sure that Emre is no longer involved with SambaPOS v5 they have an entirely separate dev team on that now. Emre is fully committed to the new project. That being said I should update my terminals and test that myself. 5.2.4 was released recently you might try updating to it but I doubt it would fix this.


#3

I tagged Emre since I know he looked into issues related to touch before so hopefully might have some insight on this. I’m very concerned about this as that’s 3 tablets not related to each other this happened on and we sell a lot of SambaPOS on tablets. This could end up being quite a serious issue for us (and others too…).

Yeah you use Surface tablets right? I don’t suggest you do it on a live tablet as otherwise you might end up having to revert back to previous build of Windows if it ends up being related to the Windows build. But yeah please test it if you can need to really get to the bottom of this.


#4

What we have on the right side of the screen is a transparent window that handles the popup column. I think that area is exactly same width of a popup. I don’t think it relates with a change on SambaPOS. That is a transparent window so it shouldn’t capture touch inputs. That part really didn’t changed since V2 version.

Such weird issues generally relates with graphic drivers. You can try starting SambaPOS with -softrender switch to disable hardware acceleration. It may help. Also a windows update that changes something related with wpf might also be the reason of it. If it is the case we don’t have too much options. Team will try to reproduce it on a development machine and try to find a workaround if possible.

The day MS stopped WPF development I worried about having such issues. I don’t know how many people left on WPF team but I’m sure they’re working hard to fix issues related with some native changes windows internals. On every windows update I notice a small change on how windows handles app screens.


#5

Yeah I edited my post afterwards, I don’t think it’s related to SambaPOS version either - the customer who reported this to me is using v5.2.2.

This is definitely the issue when loading without any switches. I can’t touch anything under this transparent window (although on the keypad, the numbers highlight but don’t “click”).

When using -notablet switch, that makes the width less, so the transparent window width is greater than the width that can’t be touched. I will try to illustrate comparing to the video.

I can also confirm it appears to be related to that transparent window, because I can touch the transparent window right on the far right without problem.

I tried -softrender just now but it makes no difference. Also, -notablet -softrender also doesn’t help, just the same as -notablet itself so just makes the area that touch doesn’t respond less.

Tablet is using Intel graphics which is going to be pretty standard across all tablets. I will see if there is a driver update from Intel.


#6

It happens for me too. It works fine when I first start SambaPOS but starts ignoring touches after showing first popup.

The difference on my case is the width of the area is exactly the width of the popup. That may relate with scaling. Also my buttons highlights fine when I touch. It just ignores the clicks.

-notablet worked fine for me. This is expected because when used it converts touch events to mouse clicks. There is still a thin inactive area though. Maybe as wide as a scroll bar.

regarding the issue @mehmet told me they’ll prepare a test build with the latest .net framework and let us know when it is ready. @markjw I’ll be glad if you can try it and let us know if it makes a difference or not.


#7

It’s the same for me, when I don’t use -notablet.

Yeah, this thin inactive area for me is the area I highlighted in the image in previous post. It makes it just usable, but difficult to click Main Menu and not possible to click the X next to the input field above the numberpad. Otherwise yes it is almost useable, but…

I didn’t post this earlier as didn’t want to confuse matters as not directly related to this. On this specific setup customer wants to be able to key in items code on the numberpad (i.e. we set item code as barcode) and they have letters in their item codes… 18 letters of the alphabet! So we had to use a custom keyboard:

So with my custom keyboard, the thin area covers the entire last column of the custom keyboard, so can’t access 3 6 9 x <enter>.

I’ve updated graphics drivers to latest available, dated May 2018. Previously had drivers from April 2016. However made no difference.


#8

So I feel like this is a WPF issue. First we need to understand if targeting latest .net framework on SambaPOS solves it or not. If it does no change we’ll consider other options.


#9

Ok i read.We will test it. I will change .Net version for the solution firstly. I will update this issue after doing that.


#10

@markjw I tested in two Windows 7 Device and one Windows 10 Laptop with touch screen. And i didnt catch this problem. Waiting for new Windows 10 devices. I will test again with new devices. But want to ask two question.
1- Did you get any error with mouse clicking in this area?
2- Did you test it in registered version?


#11

This problem does not occur in Windows 7

Check with @emre he also said he can reproduce this…

Please read the rest of the topic, I already mentioned everything about it and posted videos… I think you don’t understand the problem.

Yes. The video I posted was from trial mode because I hadn’t added license, but after I added license the same problem shows. As Emre mentioned, he said it only happens after a popup appears. So in my case when I was testing it was trial so I had an activation popup immediately, so I didn’t notice then whether it was related to that or not. But there are other reasons a popup will appear like for Caller ID which we use on that system. As Emre said, it is related to the transparent window that exists for the popups.


#12

1-We must test it with all kind of devices, like Windows 7 so we understand that Windows 7 have got no error.
2-Yes i read that Emre reproduce this. But we must catch this with many devices/OS’s to understand what is wrong.
We still testing for understanding clearly.


#13

It’s good to see that this issue is finally getting some traction. I had to use a completely new computer to get past this issue.


#14

With the default Advanced Delivery Screen Setup when switching departments maybe 4-5 times kind of quickly i get a crash that i reported to Tayfun. After sambaPOS loads up again there is weird issue of right side pin pad buttons on login screen interacting (blue color) but not actually entering button in field.

Latest update of windows 10 enterprise. SambaPOS v 5.2.3 I have not tried on 5.2.4

Just thought id mention that


#15

What is actually happening here is when it crashes and loads again, you get a popup about Detailed Logging being activated. This popup then makes this issue appear. It’s likely you haven’t had any popup appear beforehand so you didn’t experience the issue. If you are using activated license and not using any popups for things like Caller ID, you wouldn’t have any popup before. See below…


#16

Has the problem been identified yet?

edit: I had to disable my caller-id, in order for it to accept touches.


#17

Yes we are working on it. I think in new release we will fix that problem.


#18

I’ve just noticed that doesn’t happening for me anymore. @markjw can you check if latest windows updates solves it for you or not?


#19

Huh. Really ? I love this news :slight_smile:


#20

no sorry false alarm… notablet setting somehow remained on my shortcut …