Remote SQL not connecting, possible AP problem?

Really depends on a few things that could interfere with wifi connections.
Wifi deadspots
Simply a bad AP
Or a good AP but bad coverage through brick walls.
Could be a combination of things

I’m going to move the system into my living room.

Hopefully fingers crossed that works. As I said I’ve set up a few servers so pretty much know any problem going but this stumped me.


I’ve generally avoided a remote SQL terminal over wifi, generally use either wired or RDP/teamviewer to a wired machine.

Na, I get you but its for multi terminal.

Ive literally tried everything here it doing my nut in. Last one I built just ‘worked’! grr
Ok Ive just hard wired the server so ill try now.

Make sure computers/terminals have WIFI connection set to Private and not Public.

Wired is automatically Private.

Its bizarre, I can see the servers files on my laptop but it wont connect to the sql server.

I feel ive exhausted all options… theres going to be a small thing ive missed I know it

ive gone through this twice

Ive aloso gone through the multi terminal tutorial about 4 times to make sure I didn’t miss anything…

My router is a standard SKY router.

If you haven’t already, look at this post as well…

NO I didn’t see that one, but I’m going to go through it now.

I actually have the firewall turned off at the moment, but ill tun back on and add these ports

The pipes is always what I forget.

Yeah did them first…

It’s proper bizarre. Might uninstall sql and reinstall again… Might have done something wrong

Generally you would expect some sort of connectivity if setup corectly.
WAPs would generally not have any form of routing/firwall being lan based and file sharing etc would suggest network structure is ok.
Obviously that doesnt mean SQL is a set thing but suggests network is ok…
Guessing you cant connect via MSSQLM from laptop?

Never tried actually… I’ll do that tomorrow. Laid up in bed at the moment don’t think the wife will be happy if I pull my laptop out lol

Do you install samba using default settings? 'cause last time i had a similar problem was that installed samba on terminal wirh local db causing the issue that wont connect the server


Good point, however my connection string is set to the terminal rather than localhost.

Are you sure your connection is PRIVATE?

Connections definitely private… wow this is highly annoying lol

I spent best part of all day on it yesterday :frowning:

In the pipes the ports wernt set, so I set them as 1433 as outlined in an online tutorial, restarted server and still nope…

I absolutely have no idea, ive literally exhausted everything.

I’m connected to a homegroup, all connections are private, all tutorial and troubleshooting options triple checked.

I’m thinking of just deleting the lot and starting again, but I haven’t done anything major to warrant that

the error I’m getting is this:

(provider: SQL Network Interfaces, error: 28 - Server doesn’t support requested protocol)

ive disabled Named Pipes as detailed here

I am now awaiting a reboot

still no go, SSMS doesn’t connect remotely either

my laptop I’m using sql server 2014 and the server is using 2016, but that shouldn’t make a difference?

Uninstalled all instances, started from scratch.

Still nothing, I really am at a loss here


Pinging with 32 bytes of data:
Reply from bytes=32 time=2ms TTL=128
Reply from bytes=32 time=2ms TTL=128
Reply from bytes=32 time=2ms TTL=128
Reply from bytes=32 time=10ms TTL=128

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 2ms, Maximum = 10ms, Average = 4ms


I can ping it :confused:

Is SQL server agent running? It would be a service.