[Resolved] Adding Gratuity Manually

Hello everyone,

I need an option to add 18% Gratuity manually to a Ticket. I followed Emre’s tutorial below, but this does not show under Ticket section. It shows under payment screen.

I would like it to work in the following manner:

  1. Show under Ticket section
  2. Gratuity should not increase tax collected
  3. I need to be able to turn on and off by clicking “Gratuity 18%” button

Thank you in advance.

[Emre Tutorial][1]
[1]: How to add services charge?

Be sure Tax Included option is checked for the calculation type

You would need to delete the Calculation Selector and instead make it an automation command with an action to execute the calculation.

To turn it off you simply just press button again. Toggle Calculation has to be selected



Thank you for quick reply. I created an Action, Rule and Automation Command. It is almost working except it is adding $18 to Ticket Total. I need to add 18% to Ticket Total.

Also, what should I add to Ticket Template to print Gratuity.

Many thanks.

{CALCULATION TOTAL:X} X = Calculation name

You did not select fixed amount like in my screenshot did you? I did not mean for you to set it to Fixed amount I was just wanting you to look at the arrows

I tried “Rate from ticket Amount” but it did not work.

Did you have it set as 0 in the calculation type? Maybe let the action define the amount. Or put it as variable and let Rule Define it. If that does not work maybe try setting it as variable and use an expression in the rule.


Not sure what I am doing wrong, but it keeps adding $18 instead of 18%

Thank you,

You set calculation method as FIX AMOUNT instead of RATE from total amount


I tried both “Rate from ticket Amount” and “Fixed Amount” and it is just adding $18. Thanks.

I will look at it when I get home

Thank you very much. @kendash

It works just fine exactly as I showed you how to make it… one exception I did not mean for you to copy my action. You need to change Calculation Method to Rate from Ticket make sure Rate or Amount is 0. Max is 0 and Rounding is 0. Check Include Tax, Use Plain Sum, and Toggle Calculation. Then follow rest of what I told you to do. You probably need to log out and log back in for calculation type to take affect.

If you want the gratuitity to be based off the balance which is tax included then uncheck Use Plain Sum

1 Like


Thank you for your help again. Gratuity was set-up properly at the beginning. I just kept forgetting to Log Off. :frowning:

1 Like